summaryrefslogtreecommitdiff
path: root/dev-go/go-sqlite3/go-sqlite3-1.1.0_p20160307.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-go/go-sqlite3/go-sqlite3-1.1.0_p20160307.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-go/go-sqlite3/go-sqlite3-1.1.0_p20160307.ebuild')
-rw-r--r--dev-go/go-sqlite3/go-sqlite3-1.1.0_p20160307.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-go/go-sqlite3/go-sqlite3-1.1.0_p20160307.ebuild b/dev-go/go-sqlite3/go-sqlite3-1.1.0_p20160307.ebuild
new file mode 100644
index 000000000000..9779c6f59d34
--- /dev/null
+++ b/dev-go/go-sqlite3/go-sqlite3-1.1.0_p20160307.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit golang-build golang-vcs-snapshot
+
+EGO_PN="github.com/mattn/go-sqlite3/..."
+EGIT_COMMIT="10876d7dac65f02064c03d7372a2f1dfb90043fe"
+ARCHIVE_URI="https://${EGO_PN%/*}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+KEYWORDS="~amd64"
+
+DESCRIPTION="Go sqlite3 driver using database/sql"
+HOMEPAGE="https://github.com/mattn/go-sqlite3"
+SRC_URI="${ARCHIVE_URI}"
+LICENSE="MIT"
+SLOT="0/${PVR}"
+IUSE=""
+
+src_compile() {
+ GOPATH="${S}" \
+ go install -v -work -x ${EGO_BUILD_FLAGS} "${EGO_PN}" || die
+}
+
+src_install() {
+ golang_install_pkgs
+}
+
+golang_install_pkgs() {
+ insinto $(dirname "${EPREFIX}$(get_golibdir)/src/${EGO_PN%/*}")
+ rm -rf "${S}"/src/${EGO_PN%/*}/.git*
+ doins -r "${S}"/src/${EGO_PN%/*}
+ insinto $(dirname "${EPREFIX}$(get_golibdir)/pkg/$(go env GOOS)_$(go env GOARCH)/${EGO_PN%/*}")
+ doins -r "${S}"/pkg/$(go env GOOS)_$(go env GOARCH)/${EGO_PN%/*}{,.a}
+}