summaryrefslogtreecommitdiff
path: root/dev-go/go-critic/go-critic-0.6.4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-08-24 20:48:34 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-08-24 20:48:34 +0100
commit9d0673651c57438d51e18c6b8ca894d0491b2df3 (patch)
treec5b6cd187b8998d2c56d3b279ac425973d4c3a33 /dev-go/go-critic/go-critic-0.6.4.ebuild
parentbe21a4c281fc76681a84dd2f103e850866ce4946 (diff)
gentoo auto-resync : 24:08:2022 - 20:48:33
Diffstat (limited to 'dev-go/go-critic/go-critic-0.6.4.ebuild')
-rw-r--r--dev-go/go-critic/go-critic-0.6.4.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-go/go-critic/go-critic-0.6.4.ebuild b/dev-go/go-critic/go-critic-0.6.4.ebuild
new file mode 100644
index 000000000000..2518b9ed74ee
--- /dev/null
+++ b/dev-go/go-critic/go-critic-0.6.4.ebuild
@@ -0,0 +1,25 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit go-module
+
+DESCRIPTION="The most opinionated Go source code linter for code audit"
+HOMEPAGE="https://github.com/go-critic/go-critic"
+SRC_URI="https://github.com/go-critic/go-critic/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI+=" https://dev.gentoo.org/~williamh/dist/${P}-deps.tar.xz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+# tests fail
+RESTRICT="test"
+
+src_compile() {
+ emake GOCRITIC_VERSION=v${PV} build-release
+}
+
+src_install() {
+ dobin bin/*
+}