summaryrefslogtreecommitdiff
path: root/dev-go/glide/glide-0.13.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-02-24 19:58:07 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-02-24 19:58:07 +0000
commit99abbc5e5a6ecd3fc981b45646fd8cb5d320377b (patch)
treeda76713365257a445f3ae3b95470917f59d46728 /dev-go/glide/glide-0.13.1.ebuild
parent4935506e9a5cbfabd37c64093eac5f36c2ff0017 (diff)
gentoo resync : 24.02.2018
Diffstat (limited to 'dev-go/glide/glide-0.13.1.ebuild')
-rw-r--r--dev-go/glide/glide-0.13.1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-go/glide/glide-0.13.1.ebuild b/dev-go/glide/glide-0.13.1.ebuild
new file mode 100644
index 000000000000..ea72460755a3
--- /dev/null
+++ b/dev-go/glide/glide-0.13.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+EGO_PN="github.com/Masterminds/glide"
+
+if [[ ${PV} == *9999 ]]; then
+ inherit golang-vcs
+else
+ SRC_URI="https://${EGO_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+ inherit golang-vcs-snapshot
+fi
+
+DESCRIPTION="Vendor Package Managment for Golang"
+HOMEPAGE="https://github.com/Masterminds/glide"
+
+LICENSE="MIT"
+SLOT="0"
+IUSE=""
+
+RESTRICT="test"
+
+S=${WORKDIR}/${P}/src/${EGO_PN}
+
+src_compile() {
+ GOPATH="${WORKDIR}/${P}:$(get_golibdir_gopath)" go build -ldflags="-X main.version=${PV}" -o "bin/glide" glide.go || die
+}
+
+src_install() {
+ dodoc README.md CHANGELOG.md
+ dobin bin/glide
+}