summaryrefslogtreecommitdiff
path: root/dev-go/fuzzy/fuzzy-0.0.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-go/fuzzy/fuzzy-0.0.3.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-go/fuzzy/fuzzy-0.0.3.ebuild')
-rw-r--r--dev-go/fuzzy/fuzzy-0.0.3.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-go/fuzzy/fuzzy-0.0.3.ebuild b/dev-go/fuzzy/fuzzy-0.0.3.ebuild
new file mode 100644
index 000000000000..6ea5cd48cd42
--- /dev/null
+++ b/dev-go/fuzzy/fuzzy-0.0.3.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+EGO_PN=github.com/sahilm/fuzzy
+
+if [[ ${PV} = *9999* ]]; then
+ inherit golang-vcs
+else
+ KEYWORDS="~amd64"
+ SRC_URI="https://${EGO_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ inherit golang-vcs-snapshot
+fi
+inherit golang-build
+
+DESCRIPTION="Go library that provides fuzzy string matching"
+HOMEPAGE="https://github.com/sahilm/fuzzy"
+LICENSE="MIT"
+SLOT="0/${PVR}"
+IUSE="test"
+
+DEPEND="test? ( dev-go/godebug-pretty )"
+RDEPEND=""
+
+src_install() {
+ golang-build_src_install
+
+ pushd "src/${EGO_PN}" >/dev/null || die
+ einstalldocs
+ popd >/dev/null || die
+}