summaryrefslogtreecommitdiff
path: root/dev-gap/polymaking
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-01-22 16:48:54 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-01-22 16:48:54 +0000
commitce163dcd0944d81d8406c9532b457535efca7a6d (patch)
treef7deea170544ce69e03c037101b7b5c1277966b4 /dev-gap/polymaking
parent05ee8049e2326946a2cd1720f98384c864f0a804 (diff)
gentoo auto-resync : 22:01:2024 - 16:48:54
Diffstat (limited to 'dev-gap/polymaking')
-rw-r--r--dev-gap/polymaking/Manifest3
-rw-r--r--dev-gap/polymaking/metadata.xml26
-rw-r--r--dev-gap/polymaking/polymaking-0.8.7.ebuild22
3 files changed, 51 insertions, 0 deletions
diff --git a/dev-gap/polymaking/Manifest b/dev-gap/polymaking/Manifest
new file mode 100644
index 000000000000..5cda23a468b6
--- /dev/null
+++ b/dev-gap/polymaking/Manifest
@@ -0,0 +1,3 @@
+DIST polymaking-0.8.7.tar.gz 281215 BLAKE2B 32fda84ae1d03a4a70bd0f250a39495dbf0bf773e0df3fe194d364a1b3a458f7512dd5e93e22ee36b099deac6e85f5b108b8b89a5a0d426a6f2f14005766daca SHA512 c1162414d99e8c059fc85e4356c099b2ff22b8974632262e7b694ebe28bcc947ca3f64bccae2c655af91696070b31762da199a02e4115ffef4bf20058b511c0f
+EBUILD polymaking-0.8.7.ebuild 487 BLAKE2B af50d22afe0a24dd4dcfe25809e0d0eecbf16cf1ab5c6d646f90aff3b14912dac113a95f8c9f7d8d3d6776ba7a17299526e0a2e6fdaff5fc927d7f2ff350ca7a SHA512 26c8f86837682401fb7034d096700cbd2fac98dc45c634e8bd78a64afff1b01f74931933f081e1374961dbad80dd824f179f3b02582b45fac5377f62dd26c654
+MISC metadata.xml 876 BLAKE2B f0605c698d54d9a44ad5973c177aaa788f9e67ccb37d663222f711b0608673361c55f8af061ae317f23d9554c98f3e3167595cb2e4812c48cd2a309d0b3a4317 SHA512 c328b93eb04c9146d199dbb83ccfd1d374b11002c260ed93d118295734c29452c0753f5c9ead112a81376d4de0a59ae84046cf87e9fac4d16f024253c9dde5c2
diff --git a/dev-gap/polymaking/metadata.xml b/dev-gap/polymaking/metadata.xml
new file mode 100644
index 000000000000..75d289ff81f9
--- /dev/null
+++ b/dev-gap/polymaking/metadata.xml
@@ -0,0 +1,26 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>mjo@gentoo.org</email>
+ </maintainer>
+ <maintainer type="person">
+ <email>frp.bissey@gmail.com</email>
+ <name>François Bissey</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>sci-mathematics@gentoo.org</email>
+ <name>Gentoo Mathematics Project</name>
+ </maintainer>
+ <longdescription lang="en">
+ This package provides a very basic interface to the polymake program
+ by Ewgenij Gawrilow, Michael Joswig et al.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">gap-packages/polymaking</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-gap/polymaking/polymaking-0.8.7.ebuild b/dev-gap/polymaking/polymaking-0.8.7.ebuild
new file mode 100644
index 000000000000..e488b8819e71
--- /dev/null
+++ b/dev-gap/polymaking/polymaking-0.8.7.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gap-pkg
+
+DESCRIPTION="GAP interface to sci-mathematics/polymake"
+SRC_URI="https://github.com/gap-packages/${PN}/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64"
+
+# Tests fail: https://github.com/gap-packages/polymaking/issues/18
+RESTRICT=test
+
+RDEPEND="sci-mathematics/polymake"
+
+DOCS=( CHANGES.md README.md )
+
+gap-pkg_enable_tests