summaryrefslogtreecommitdiff
path: root/dev-games/t4k-common/t4k-common-0.1.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-games/t4k-common/t4k-common-0.1.1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-games/t4k-common/t4k-common-0.1.1.ebuild')
-rw-r--r--dev-games/t4k-common/t4k-common-0.1.1.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/dev-games/t4k-common/t4k-common-0.1.1.ebuild b/dev-games/t4k-common/t4k-common-0.1.1.ebuild
new file mode 100644
index 000000000000..ed40644465c3
--- /dev/null
+++ b/dev-games/t4k-common/t4k-common-0.1.1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit eutils
+
+DESCRIPTION="A library of code shared between tuxmath and tuxtype"
+HOMEPAGE="http://tux4kids.alioth.debian.org/tuxmath/download.php"
+SRC_URI="http://alioth.debian.org/frs/download.php/3540/t4k_common-${PV}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="static-libs svg"
+
+RDEPEND="dev-libs/libxml2:2
+ media-libs/libsdl
+ media-libs/sdl-image
+ media-libs/sdl-mixer
+ media-libs/sdl-net
+ media-libs/sdl-ttf
+ media-libs/sdl-pango
+ svg? (
+ gnome-base/librsvg:2
+ media-libs/libpng:0
+ x11-libs/cairo
+ )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+S=${WORKDIR}/t4k_common-${PV}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-libpng.patch
+}
+
+src_configure() {
+ econf \
+ $(usex svg "" "--without-rsvg") \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ use static-libs || prune_libtool_files --all
+}