summaryrefslogtreecommitdiff
path: root/dev-games/t4k-common/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
commitd934827bf44b7cfcf6711964418148fa60877668 (patch)
tree0625f358789b5e015e49db139cc1dbc9be00428f /dev-games/t4k-common/files
parent2e34d110f164bf74d55fced27fe0000201b3eec5 (diff)
gentoo resync : 25.11.2020
Diffstat (limited to 'dev-games/t4k-common/files')
-rw-r--r--dev-games/t4k-common/files/t4k-common-0.1.1-ICONV_CONST.patch10
-rw-r--r--dev-games/t4k-common/files/t4k-common-0.1.1-fno-common.patch11
-rw-r--r--dev-games/t4k-common/files/t4k-common-0.1.1-libpng.patch4
3 files changed, 23 insertions, 2 deletions
diff --git a/dev-games/t4k-common/files/t4k-common-0.1.1-ICONV_CONST.patch b/dev-games/t4k-common/files/t4k-common-0.1.1-ICONV_CONST.patch
new file mode 100644
index 000000000000..037d2acd292b
--- /dev/null
+++ b/dev-games/t4k-common/files/t4k-common-0.1.1-ICONV_CONST.patch
@@ -0,0 +1,10 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -39,6 +39,7 @@
+ AC_PROG_MKDIR_P
+ AC_PROG_YACC
+ AC_PROG_LIBTOOL
++AM_ICONV
+
+
+ # -----------------------------------------------------------------------
diff --git a/dev-games/t4k-common/files/t4k-common-0.1.1-fno-common.patch b/dev-games/t4k-common/files/t4k-common-0.1.1-fno-common.patch
new file mode 100644
index 000000000000..2bdf418649c2
--- /dev/null
+++ b/dev-games/t4k-common/files/t4k-common-0.1.1-fno-common.patch
@@ -0,0 +1,11 @@
+--- a/src/t4k_common.h
++++ b/src/t4k_common.h
+@@ -239,7 +239,7 @@
+ #define MAX_LINES 128 //!< Maximum lines to wrap.
+ #define MAX_LINEWIDTH 256 //!< Maximum characters of each line.
+
+-char wrapped_lines[MAX_LINES][MAX_LINEWIDTH]; //!< Global buffer for wrapped lines.
++extern char wrapped_lines[MAX_LINES][MAX_LINEWIDTH]; //!< Global buffer for wrapped lines.
+
+ //TODO separate headers for different areas a la SDL?
+
diff --git a/dev-games/t4k-common/files/t4k-common-0.1.1-libpng.patch b/dev-games/t4k-common/files/t4k-common-0.1.1-libpng.patch
index 29991544ddbf..fad91de2d205 100644
--- a/dev-games/t4k-common/files/t4k-common-0.1.1-libpng.patch
+++ b/dev-games/t4k-common/files/t4k-common-0.1.1-libpng.patch
@@ -1,5 +1,5 @@
---- src/t4k_common-0.1.1/src/t4k_loaders.c 2011-04-08 05:46:07.000000000 +0300
-+++ src.new/t4k_common-0.1.1/src/t4k_loaders.c 2012-05-02 10:35:41.836670434 +0300
+--- a/src/t4k_loaders.c
++++ b/src/t4k_loaders.c
@@ -1028,12 +1028,9 @@
{
png_init_io(png_ptr, fi);