summaryrefslogtreecommitdiff
path: root/dev-games/simgear/simgear-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-games/simgear/simgear-9999.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-games/simgear/simgear-9999.ebuild')
-rw-r--r--dev-games/simgear/simgear-9999.ebuild62
1 files changed, 62 insertions, 0 deletions
diff --git a/dev-games/simgear/simgear-9999.ebuild b/dev-games/simgear/simgear-9999.ebuild
new file mode 100644
index 000000000000..6ee236bee6f8
--- /dev/null
+++ b/dev-games/simgear/simgear-9999.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit eutils cmake-utils toolchain-funcs git-r3
+
+DESCRIPTION="Development library for simulation games"
+HOMEPAGE="http://www.simgear.org/"
+EGIT_REPO_URI="git://git.code.sf.net/p/flightgear/${PN}
+ git://mapserver.flightgear.org/${PN}"
+EGIT_BRANCH="next"
+
+LICENSE="GPL-2"
+KEYWORDS=""
+SLOT="0"
+IUSE="+dns debug gdal openmp subversion test"
+
+COMMON_DEPEND="
+ dev-libs/expat
+ >=dev-games/openscenegraph-3.2.0
+ media-libs/openal
+ net-misc/curl
+ sys-libs/zlib
+ virtual/opengl
+ dns? ( net-libs/udns )
+ gdal? ( sci-libs/gdal )
+"
+DEPEND="${COMMON_DEPEND}
+ >=dev-libs/boost-1.44
+"
+RDEPEND="${COMMON_DEPEND}
+ subversion? ( dev-vcs/subversion )
+"
+
+pkg_pretend() {
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
+}
+
+pkg_setup() {
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DENABLE_DNS=$(usex dns)
+ -DENABLE_GDAL=$(usex gdal)
+ -DENABLE_OPENMP=$(usex openmp)
+ -DENABLE_PKGUTIL=ON
+ -DENABLE_RTI=OFF
+ -DENABLE_SIMD=ON
+ -DENABLE_SOUND=ON
+ -DENABLE_TESTS=$(usex test)
+ -DSIMGEAR_HEADLESS=OFF
+ -DSIMGEAR_SHARED=ON
+ -DSYSTEM_EXPAT=ON
+ -DSYSTEM_UDNS=ON
+ -DUSE_AEONWAVE=OFF
+ -DOSG_FSTREAM_EXPORT_FIXED=OFF # TODO perhaps track it
+ )
+ cmake-utils_src_configure
+}