summaryrefslogtreecommitdiff
path: root/dev-games/simgear/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-games/simgear/files
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-games/simgear/files')
-rw-r--r--dev-games/simgear/files/simgear-2017.2.1-boost-1.65-tr1-removal.patch47
-rw-r--r--dev-games/simgear/files/simgear-2017.2.1-gdal-underlinking.patch28
2 files changed, 75 insertions, 0 deletions
diff --git a/dev-games/simgear/files/simgear-2017.2.1-boost-1.65-tr1-removal.patch b/dev-games/simgear/files/simgear-2017.2.1-boost-1.65-tr1-removal.patch
new file mode 100644
index 000000000000..a9ebe507cee4
--- /dev/null
+++ b/dev-games/simgear/files/simgear-2017.2.1-boost-1.65-tr1-removal.patch
@@ -0,0 +1,47 @@
+--- a/simgear/scene/material/Effect.cxx
++++ b/simgear/scene/material/Effect.cxx
+@@ -32,7 +32,7 @@
+ #include <map>
+ #include <queue>
+ #include <utility>
+-#include <boost/tr1/unordered_map.hpp>
++#include <boost/unordered_map.hpp>
+
+ #include <boost/bind.hpp>
+ #include <boost/foreach.hpp>
+@@ -832,13 +832,13 @@
+
+ // XXX Should these be protected by a mutex? Probably
+
+-typedef tr1::unordered_map<ProgramKey, ref_ptr<Program>,
++typedef boost::unordered_map<ProgramKey, ref_ptr<Program>,
+ boost::hash<ProgramKey>, ProgramKey::EqualTo>
+ ProgramMap;
+ ProgramMap programMap;
+ ProgramMap resolvedProgramMap; // map with resolved shader file names
+
+-typedef tr1::unordered_map<ShaderKey, ref_ptr<Shader>, boost::hash<ShaderKey> >
++typedef boost::unordered_map<ShaderKey, ref_ptr<Shader>, boost::hash<ShaderKey> >
+ ShaderMap;
+ ShaderMap shaderMap;
+
+--- a/simgear/scene/material/Effect.hxx
++++ b/simgear/scene/material/Effect.hxx
+@@ -19,7 +19,7 @@
+
+ #include <vector>
+ #include <string>
+-#include <boost/tr1/unordered_map.hpp>
++#include <boost/unordered_map.hpp>
+
+ #include <boost/functional/hash.hpp>
+
+@@ -127,7 +127,7 @@
+ bool operator()(const Key& lhs, const Key& rhs) const;
+ };
+ };
+- typedef std::tr1::unordered_map<Key, osg::observer_ptr<Effect>,
++ typedef boost::unordered_map<Key, osg::observer_ptr<Effect>,
+ boost::hash<Key>, Key::EqualTo> Cache;
+ Cache* getCache()
+ {
diff --git a/dev-games/simgear/files/simgear-2017.2.1-gdal-underlinking.patch b/dev-games/simgear/files/simgear-2017.2.1-gdal-underlinking.patch
new file mode 100644
index 000000000000..63eb79ed35ce
--- /dev/null
+++ b/dev-games/simgear/files/simgear-2017.2.1-gdal-underlinking.patch
@@ -0,0 +1,28 @@
+From 9971d517fdf351e40467c88915d3e30e56f999d4 Mon Sep 17 00:00:00 2001
+From: Maciej Mrozowski <reavertm@gmail.com>
+Date: Thu, 15 Jun 2017 04:58:03 +0200
+Subject: [PATCH] Link shared SimGearScene with libgdal when enabled
+
+---
+ simgear/CMakeLists.txt | 5 +++++
+ 1 file changed, 5 insertions(+)
+
+diff --git a/simgear/CMakeLists.txt b/simgear/CMakeLists.txt
+index 18c2e04c..6c7cb495 100644
+--- a/simgear/CMakeLists.txt
++++ b/simgear/CMakeLists.txt
+@@ -173,6 +173,11 @@ if(NOT SIMGEAR_HEADLESS)
+ ${OPENGL_LIBRARY}
+ ${JPEG_LIBRARY})
+
++ if(ENABLE_GDAL)
++ target_link_libraries(SimGearScene
++ ${GDAL_LIBRARIES})
++ endif()
++
+ # only actually needed by canvas/KeyboardEvent.cxx
+ target_include_directories(SimGearScene PRIVATE ${PROJECT_SOURCE_DIR}/3rdparty/utf8/source)
+ endif()
+--
+2.13.0
+