summaryrefslogtreecommitdiff
path: root/dev-games/ps2-packer/ps2-packer-0.4.4-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
commit40aaaa64e86ba6710bbeb31c4615a6ce80e75e11 (patch)
tree758c221bad35c9288d0bd6df9c7dfc226728e52c /dev-games/ps2-packer/ps2-packer-0.4.4-r1.ebuild
parent8d5dbd847cbc704a6a06405856e94b461011afe3 (diff)
gentoo resync : 28.04.2021
Diffstat (limited to 'dev-games/ps2-packer/ps2-packer-0.4.4-r1.ebuild')
-rw-r--r--dev-games/ps2-packer/ps2-packer-0.4.4-r1.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/dev-games/ps2-packer/ps2-packer-0.4.4-r1.ebuild b/dev-games/ps2-packer/ps2-packer-0.4.4-r1.ebuild
new file mode 100644
index 000000000000..5d3ee26ac3e7
--- /dev/null
+++ b/dev-games/ps2-packer/ps2-packer-0.4.4-r1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit wrapper
+
+DESCRIPTION="Another ELF packer for the PS2"
+HOMEPAGE="https://github.com/ps2dev/ps2-packer"
+SRC_URI="mirror://gentoo/${P}-linux.tar.gz"
+S="${WORKDIR}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-* amd64 x86"
+RESTRICT="strip"
+
+QA_TEXTRELS="
+ opt/ps2-packer/n2e-packer.so
+ opt/ps2-packer/n2d-packer.so
+ opt/ps2-packer/n2b-packer.so"
+
+QA_WX_LOAD="
+ opt/ps2-packer/stub/n2e-0088-stub
+ opt/ps2-packer/stub/lzo-0088-stub
+ opt/ps2-packer/stub/n2e-asm-1d00-stub
+ opt/ps2-packer/stub/null-0088-stub
+ opt/ps2-packer/stub/n2e-asm-one-1d00-stub
+ opt/ps2-packer/stub/n2e-1d00-stub
+ opt/ps2-packer/stub/zlib-1d00-stub
+ opt/ps2-packer/stub/n2b-0088-stub
+ opt/ps2-packer/stub/n2d-1d00-stub
+ opt/ps2-packer/stub/null-1d00-stub
+ opt/ps2-packer/stub/n2b-1d00-stub
+ opt/ps2-packer/stub/zlib-0088-stub
+ opt/ps2-packer/stub/lzo-1d00-stub
+ opt/ps2-packer/stub/n2d-0088-stub"
+
+RDEPEND="sys-libs/glibc"
+
+src_install() {
+ insinto /opt/${PN}
+ doins -r README.txt stub
+
+ exeinto /opt/${PN}
+ doexe *.so ps2-packer
+
+ make_wrapper ${PN} /opt/${PN}/${PN}
+}