summaryrefslogtreecommitdiff
path: root/dev-games/physfs/physfs-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-05-18 00:10:51 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-05-18 00:10:51 +0100
commiteccb70a7f91b2d22582587f26d1a28bb31408b45 (patch)
tree3223e1fd54201bcf4ebecac6fbe87361cbe643e2 /dev-games/physfs/physfs-9999.ebuild
parenta2810985afabcc31d3eace5e61d8ea25b852ba17 (diff)
gentoo resync : 18.05.2019
Diffstat (limited to 'dev-games/physfs/physfs-9999.ebuild')
-rw-r--r--dev-games/physfs/physfs-9999.ebuild11
1 files changed, 4 insertions, 7 deletions
diff --git a/dev-games/physfs/physfs-9999.ebuild b/dev-games/physfs/physfs-9999.ebuild
index 683b49ac714d..91229a1b6d98 100644
--- a/dev-games/physfs/physfs-9999.ebuild
+++ b/dev-games/physfs/physfs-9999.ebuild
@@ -2,6 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
+
inherit cmake-multilib
DESCRIPTION="Abstraction layer for filesystem and archive access"
@@ -44,13 +45,9 @@ multilib_src_configure() {
multilib_src_compile() {
cmake-utils_src_compile
- multilib_is_native_abi && use doc && cmake-utils_src_compile docs
-}
-multilib_src_install_all() {
- einstalldocs
- if use doc ; then
- docinto html
- dodoc -r "${CMAKE_BUILD_DIR}"/docs/html/*
+ if multilib_is_native_abi && use doc; then
+ cmake-utils_src_compile docs
+ HTML_DOCS=( "${BUILD_DIR}"/docs/html/. )
fi
}