summaryrefslogtreecommitdiff
path: root/dev-games/openscenegraph-qt/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-04-19 14:14:48 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-04-19 14:14:48 +0100
commit5cfef3c94cd7e82136c69a0322f5ba21f7e64632 (patch)
tree8f255dfacbacb657e3ac3654d01c1e11e651c066 /dev-games/openscenegraph-qt/files
parent8aebb228036d5e2863b7eaa6e319ab41c1669269 (diff)
gentoo resync : 19.04.2018
Diffstat (limited to 'dev-games/openscenegraph-qt/files')
-rw-r--r--dev-games/openscenegraph-qt/files/openscenegraph-qt-3.5.5-qt-5.11b3.patch36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-games/openscenegraph-qt/files/openscenegraph-qt-3.5.5-qt-5.11b3.patch b/dev-games/openscenegraph-qt/files/openscenegraph-qt-3.5.5-qt-5.11b3.patch
new file mode 100644
index 000000000000..9618fde498e9
--- /dev/null
+++ b/dev-games/openscenegraph-qt/files/openscenegraph-qt-3.5.5-qt-5.11b3.patch
@@ -0,0 +1,36 @@
+From 91ba61ff69dc02a412eebae6222793e803b13ec2 Mon Sep 17 00:00:00 2001
+From: Andreas Sturmlechner <asturm@gentoo.org>
+Date: Tue, 17 Apr 2018 13:47:27 +0200
+Subject: [PATCH] Fix build with Qt 5.11_beta3 (dropping qt5_use_modules)
+
+---
+ CMakeLists.txt | 1 +
+ src/osgQt/CMakeLists.txt | 2 +-
+ 2 files changed, 2 insertions(+), 1 deletion(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index aaea748..4345ea2 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -487,6 +487,7 @@ ENDIF()
+
+ #If we have found Qt5, let's try to top off by getting the webkit as well
+ IF ( Qt5Widgets_FOUND )
++ FIND_PACKAGE(Qt5OpenGL REQUIRED)
+ FIND_PACKAGE(Qt5WebKitWidgets QUIET)
+
+ IF(COMMAND cmake_policy)
+diff --git a/src/osgQt/CMakeLists.txt b/src/osgQt/CMakeLists.txt
+index 60f3250..e4523e0 100644
+--- a/src/osgQt/CMakeLists.txt
++++ b/src/osgQt/CMakeLists.txt
+@@ -85,5 +85,5 @@ ENDIF( QT4_FOUND )
+ SETUP_LIBRARY(${LIB_NAME})
+
+ IF ( Qt5Widgets_FOUND )
+- qt5_use_modules( ${LIB_NAME} Widgets OpenGL )
++ TARGET_LINK_LIBRARIES( ${LIB_NAME} Qt5::Widgets Qt5::OpenGL )
+ ENDIF ( Qt5Widgets_FOUND )
+--
+2.17.0
+