summaryrefslogtreecommitdiff
path: root/dev-games/ogre/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-06-23 07:00:28 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-06-23 07:00:28 +0100
commite23cdda4dbb0c83b9e682ab5e916085a35203da5 (patch)
tree5a4ac448a3b288b731c24d947e0ce52df3cab07b /dev-games/ogre/files
parent8187a741807f3e9a9e26304973cf18087dcf2560 (diff)
gentoo resync : 23.06.2018
Diffstat (limited to 'dev-games/ogre/files')
-rw-r--r--dev-games/ogre/files/ogre-1.10.11-fix_double_precision-88f0d5b.patch29
-rw-r--r--dev-games/ogre/files/ogre-1.10.11-media_path.patch18
-rw-r--r--dev-games/ogre/files/ogre-1.10.11-resource_path.patch18
-rw-r--r--dev-games/ogre/files/ogre-1.10.11-samples.patch13
4 files changed, 78 insertions, 0 deletions
diff --git a/dev-games/ogre/files/ogre-1.10.11-fix_double_precision-88f0d5b.patch b/dev-games/ogre/files/ogre-1.10.11-fix_double_precision-88f0d5b.patch
new file mode 100644
index 000000000000..53d7a0925d51
--- /dev/null
+++ b/dev-games/ogre/files/ogre-1.10.11-fix_double_precision-88f0d5b.patch
@@ -0,0 +1,29 @@
+# HG changeset patch
+# User niparx <koliap@gmail.com>
+# Date 1515160111 -7200
+# Node ID 88f0d5be23c521e7504e3f6cb2a153428efcf159
+# Parent bc4fb04c1de686c23c6207eee69ae0ca9fddcb7c
+[OGRE-592] RTShaderSystem compile error when using double precision (#622)
+
+RTShaderSystem: compile error when using double precision
+
+https://ogre3d.atlassian.net/browse/OGRE-592
+
+diff --git a/Components/RTShaderSystem/src/OgreShaderFFPTexturing.cpp b/Components/RTShaderSystem/src/OgreShaderFFPTexturing.cpp
+--- a/Components/RTShaderSystem/src/OgreShaderFFPTexturing.cpp
++++ b/Components/RTShaderSystem/src/OgreShaderFFPTexturing.cpp
+@@ -654,8 +654,12 @@
+ curFuncInvocation->pushOperand(ParameterFactory::createConstParam(Vector4(alphaValue)), Operand::OPS_IN);
+ }
+ else
+- {
+- curFuncInvocation->pushOperand(ParameterFactory::createConstParam(Vector4(colourValue.ptr())), Operand::OPS_IN);
++ {
++ curFuncInvocation->pushOperand(ParameterFactory::createConstParam(Vector4((Real)colourValue.r,
++ (Real)colourValue.g,
++ (Real)colourValue.b,
++ (Real)colourValue.a)),
++ Operand::OPS_IN);
+ }
+
+ curFuncInvocation->pushOperand(arg, Operand::OPS_OUT);
diff --git a/dev-games/ogre/files/ogre-1.10.11-media_path.patch b/dev-games/ogre/files/ogre-1.10.11-media_path.patch
new file mode 100644
index 000000000000..4d2547ab75a4
--- /dev/null
+++ b/dev-games/ogre/files/ogre-1.10.11-media_path.patch
@@ -0,0 +1,18 @@
+--- a/CMake/InstallResources.cmake 2014-10-29 12:43:49.000000000 +0100
++++ b/CMake/InstallResources.cmake 2014-10-29 12:46:10.017611431 +0100
+@@ -165,10 +165,11 @@
+
+ # CREATE CONFIG FILES - BUILD DIR VERSIONS
+ if (NOT (APPLE_IOS OR WINDOWS_STORE OR WINDOWS_PHONE))
+- set(OGRE_MEDIA_DIR_REL "${OGRE_SOURCE_DIR}/Samples/Media")
+- set(OGRE_MEDIA_DIR_DBG "${OGRE_SOURCE_DIR}/Samples/Media")
+- set(OGRE_TEST_MEDIA_DIR_REL "${OGRE_SOURCE_DIR}/Tests/Media")
+- set(OGRE_TEST_MEDIA_DIR_DBG "${OGRE_SOURCE_DIR}/Tests/Media")
++# No, they were fine already
++# set(OGRE_MEDIA_DIR_REL "${OGRE_SOURCE_DIR}/Samples/Media")
++# set(OGRE_MEDIA_DIR_DBG "${OGRE_SOURCE_DIR}/Samples/Media")
++# set(OGRE_TEST_MEDIA_DIR_REL "${OGRE_SOURCE_DIR}/Tests/Media")
++# set(OGRE_TEST_MEDIA_DIR_DBG "${OGRE_SOURCE_DIR}/Tests/Media")
+ else ()
+ # iOS needs to use relative paths in the config files
+ set(OGRE_MEDIA_DIR_REL "${OGRE_MEDIA_PATH}")
diff --git a/dev-games/ogre/files/ogre-1.10.11-resource_path.patch b/dev-games/ogre/files/ogre-1.10.11-resource_path.patch
new file mode 100644
index 000000000000..9c39dfc0762a
--- /dev/null
+++ b/dev-games/ogre/files/ogre-1.10.11-resource_path.patch
@@ -0,0 +1,18 @@
+--- a/CMake/InstallResources.cmake 2013-12-01 18:28:12.000000000 +0100
++++ b/CMake/InstallResources.cmake 2014-10-29 12:38:29.963602465 +0100
+@@ -189,10 +189,11 @@
+ set(OGRE_SAMPLES_DIR_REL "")
+ set(OGRE_SAMPLES_DIR_DBG "")
+ elseif (UNIX)
+- set(OGRE_PLUGIN_DIR_REL "${OGRE_BINARY_DIR}/lib")
+- set(OGRE_PLUGIN_DIR_DBG "${OGRE_BINARY_DIR}/lib")
+- set(OGRE_SAMPLES_DIR_REL "${OGRE_BINARY_DIR}/lib")
+- set(OGRE_SAMPLES_DIR_DBG "${OGRE_BINARY_DIR}/lib")
++# No, this was already configured above, the BINARY paths are wrong!
++# set(OGRE_PLUGIN_DIR_REL "${OGRE_BINARY_DIR}/lib")
++# set(OGRE_PLUGIN_DIR_DBG "${OGRE_BINARY_DIR}/lib")
++# set(OGRE_SAMPLES_DIR_REL "${OGRE_BINARY_DIR}/lib")
++# set(OGRE_SAMPLES_DIR_DBG "${OGRE_BINARY_DIR}/lib")
+ endif ()
+
+ if (MSVC AND NOT NMAKE)
diff --git a/dev-games/ogre/files/ogre-1.10.11-samples.patch b/dev-games/ogre/files/ogre-1.10.11-samples.patch
new file mode 100644
index 000000000000..80b989e980c4
--- /dev/null
+++ b/dev-games/ogre/files/ogre-1.10.11-samples.patch
@@ -0,0 +1,13 @@
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -536,7 +536,9 @@
+ endif ()
+
+ # Setup samples
+-add_subdirectory(Samples)
++if (OGRE_BUILD_SAMPLES)
++ add_subdirectory(Samples)
++endif ()
+
+ #Add android JNI binding
+ if(ANDROID)