summaryrefslogtreecommitdiff
path: root/dev-games/ode/ode-0.14-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
commit1798c4aeca70ac8d0a243684d6a798fbc65735f8 (patch)
treee48e19cb6fa03de18e1c63e1a93371b7ebc4eb56 /dev-games/ode/ode-0.14-r1.ebuild
parentd87262dd706fec50cd150aab3e93883b6337466d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-games/ode/ode-0.14-r1.ebuild')
-rw-r--r--dev-games/ode/ode-0.14-r1.ebuild77
1 files changed, 0 insertions, 77 deletions
diff --git a/dev-games/ode/ode-0.14-r1.ebuild b/dev-games/ode/ode-0.14-r1.ebuild
deleted file mode 100644
index 3f54e7ff25fc..000000000000
--- a/dev-games/ode/ode-0.14-r1.ebuild
+++ /dev/null
@@ -1,77 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-inherit autotools eutils
-
-DESCRIPTION="Open Dynamics Engine SDK"
-HOMEPAGE="http://ode.org/"
-SRC_URI="https://bitbucket.org/odedevs/ode/downloads/${P}.tar.gz"
-
-LICENSE="|| ( LGPL-2.1+ BSD )"
-SLOT="0/6"
-KEYWORDS="amd64 x86 ~x86-fbsd ~amd64-linux ~x86-linux"
-IUSE="debug doc double-precision examples gyroscopic static-libs"
-
-RDEPEND="examples? (
- virtual/glu
- virtual/opengl )"
-DEPEND="${RDEPEND}
- doc? ( app-doc/doxygen )"
-
-MY_EXAMPLES_DIR=/usr/share/doc/${PF}/examples
-
-src_prepare() {
- epatch "${FILESDIR}"/${PN}-0.14-gcc7.patch
-
- sed -i \
- -e "s:\$.*/drawstuff/textures:${MY_EXAMPLES_DIR}:" \
- drawstuff/src/Makefile.am \
- ode/demo/Makefile.am || die
- eautoreconf
-}
-
-src_configure() {
- # use bash (bug #335760)
- CONFIG_SHELL=/bin/bash \
- econf \
- --enable-shared \
- $(use_enable static-libs static) \
- $(use_enable debug asserts) \
- $(use_enable double-precision) \
- $(use_enable examples demos) \
- $(use_enable gyroscopic) \
- $(use_with examples drawstuff X11)
-}
-
-src_compile() {
- emake
- if use doc ; then
- cd ode/doc
- doxygen Doxyfile || die
- fi
-}
-
-src_install() {
- DOCS="CHANGELOG.txt README.md" \
- default
- prune_libtool_files
- if use doc ; then
- dohtml docs/*
- fi
- if use examples; then
- docompress -x "${MY_EXAMPLES_DIR}"
- insinto "${MY_EXAMPLES_DIR}"
- exeinto "${MY_EXAMPLES_DIR}"
- doexe drawstuff/dstest/dstest
- doins ode/demo/*.{c,cpp,h} \
- drawstuff/textures/*.ppm \
- drawstuff/dstest/dstest.cpp \
- drawstuff/src/{drawstuff.cpp,internal.h,x11.cpp}
- cd ode/demo
- local f
- for f in *.c* ; do
- doexe .libs/${f%.*}
- done
- fi
-}