summaryrefslogtreecommitdiff
path: root/dev-games/newton/newton-3.14.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-21 18:59:32 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-21 18:59:32 +0100
commit520a5b56dff7c24c9d42eafec142cb78b44f8e3e (patch)
treef562f705600dbd2292e97c0b4145787c2a8d1f97 /dev-games/newton/newton-3.14.ebuild
parent3811bc3072bf19e2be351d2c63f81532945c0f21 (diff)
gentoo resync : 21.07.2018
Diffstat (limited to 'dev-games/newton/newton-3.14.ebuild')
-rw-r--r--dev-games/newton/newton-3.14.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-games/newton/newton-3.14.ebuild b/dev-games/newton/newton-3.14.ebuild
new file mode 100644
index 000000000000..e998f8cc5f0c
--- /dev/null
+++ b/dev-games/newton/newton-3.14.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils toolchain-funcs
+
+MY_P="${PN}-dynamics-${P}"
+DESCRIPTION="Integrated solution for real time simulation of physics environments"
+HOMEPAGE="http://newtondynamics.com/forum/newton.php"
+SRC_URI="https://github.com/MADEAPPS/newton-dynamics/archive/${P}.tar.gz"
+
+LICENSE="ZLIB"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=""
+DEPEND=""
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ cmake-utils_src_prepare
+ sed -i -e '/packages/d' CMakeLists.txt || die
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_INSTALL_PREFIX=/usr/
+ -DNEWTON_DEMOS_SANDBOX=OFF
+ -DCMAKE_VERBOSE_MAKEFILE=ON
+ )
+ cmake-utils_src_configure
+}