summaryrefslogtreecommitdiff
path: root/dev-games/mygui/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
commit4cbcc855382a06088e2f016f62cafdbcb7e40665 (patch)
tree356496503d52354aa6d9f2d36126302fed5f3a73 /dev-games/mygui/files
parentfcc5224904648a8e6eb528d7603154160a20022f (diff)
gentoo resync : 20.03.2022
Diffstat (limited to 'dev-games/mygui/files')
-rw-r--r--dev-games/mygui/files/mygui-3.2.2-FHS.patch44
-rw-r--r--dev-games/mygui/files/mygui-3.2.2-build.patch61
-rw-r--r--dev-games/mygui/files/mygui-3.2.2-c++17.patch27
-rw-r--r--dev-games/mygui/files/mygui-3.2.2-underlinking.patch20
4 files changed, 0 insertions, 152 deletions
diff --git a/dev-games/mygui/files/mygui-3.2.2-FHS.patch b/dev-games/mygui/files/mygui-3.2.2-FHS.patch
deleted file mode 100644
index 14d21626ff7b..000000000000
--- a/dev-games/mygui/files/mygui-3.2.2-FHS.patch
+++ /dev/null
@@ -1,44 +0,0 @@
-From: Julian Ospald <hasufell@gentoo.org>
-Date: Sat Oct 27 22:39:31 UTC 2012
-Subject: FHS
-
-paths hardcoded until upstream fixed the logic
-
---- mygui-MyGUI3.2.2.orig/CMake/InstallResources.cmake
-+++ mygui-MyGUI3.2.2/CMake/InstallResources.cmake
-@@ -24,7 +24,7 @@
- else ()
- install(FILES
- ${MYGUI_BINARY_DIR}/bin/${FILENAME}
-- DESTINATION "bin"
-+ DESTINATION "/etc/MYGUI"
- )
- endif ()
- endfunction(install_file)
-@@ -53,7 +53,7 @@
- if (WIN32)
- set(MYGUI_MEDIA_DIR "../../Media")
- elseif (UNIX)
-- set(MYGUI_MEDIA_DIR "../share/MYGUI/Media")
-+ set(MYGUI_MEDIA_DIR "${CMAKE_INSTALL_PREFIX}/share/MYGUI/Media")
- else ()
- set(MYGUI_MEDIA_DIR "../../Media")
- endif ()
---- mygui-MyGUI3.2.2.orig/Common/Base/Ogre/BaseManager.cpp
-+++ mygui-MyGUI3.2.2/Common/Base/Ogre/BaseManager.cpp
-@@ -49,13 +49,13 @@
- mWindow(nullptr),
- mExit(false),
- mPluginCfgName("plugins.cfg"),
-- mResourceXMLName("resources.xml"),
-+ mResourceXMLName("/etc/MYGUI/resources.xml"),
- mResourceFileName("MyGUI_Core.xml")
- {
- #if MYGUI_PLATFORM == MYGUI_PLATFORM_APPLE
- mResourcePath = macBundlePath() + "/Contents/Resources/";
- #else
-- mResourcePath = "";
-+ mResourcePath = "/etc/MYGUI/";
- #endif
- }
-
diff --git a/dev-games/mygui/files/mygui-3.2.2-build.patch b/dev-games/mygui/files/mygui-3.2.2-build.patch
deleted file mode 100644
index a16b27c285b7..000000000000
--- a/dev-games/mygui/files/mygui-3.2.2-build.patch
+++ /dev/null
@@ -1,61 +0,0 @@
-diff -ru mygui-MyGUI3.2.2.orig/CMake/ConfigureBuild.cmake mygui-MyGUI3.2.2/CMake/ConfigureBuild.cmake
---- mygui-MyGUI3.2.2.orig/CMake/ConfigureBuild.cmake 2015-01-26 10:32:35.000000000 -0500
-+++ mygui-MyGUI3.2.2/CMake/ConfigureBuild.cmake 2015-03-14 01:09:40.743621643 -0400
-@@ -4,6 +4,8 @@
- # also prepare package files for pkg-config and CMake.
- #######################################################################
-
-+include(GNUInstallDirs)
-+
- # should we build static libs?
- if (MYGUI_STATIC)
- set(MYGUI_LIB_TYPE STATIC)
-@@ -47,7 +49,7 @@
- else ()
- configure_file(${MYGUI_TEMPLATES_DIR}/MYGUI.pc.in ${MYGUI_BINARY_DIR}/pkgconfig/MYGUI${MYGUI_LIB_SUFFIX}.pc @ONLY)
- endif ()
-- install(FILES ${MYGUI_BINARY_DIR}/pkgconfig/MYGUI${MYGUI_LIB_SUFFIX}.pc DESTINATION lib/pkgconfig)
-+ install(FILES ${MYGUI_BINARY_DIR}/pkgconfig/MYGUI${MYGUI_LIB_SUFFIX}.pc DESTINATION ${CMAKE_INSTALL_LIBDIR}/pkgconfig)
-
- # configure additional packages
-
-diff -ru mygui-MyGUI3.2.2.orig/CMake/Utils/MyGUIConfigTargets.cmake mygui-MyGUI3.2.2/CMake/Utils/MyGUIConfigTargets.cmake
---- mygui-MyGUI3.2.2.orig/CMake/Utils/MyGUIConfigTargets.cmake 2015-01-26 10:32:35.000000000 -0500
-+++ mygui-MyGUI3.2.2/CMake/Utils/MyGUIConfigTargets.cmake 2015-03-14 01:08:44.905791784 -0400
-@@ -1,6 +1,8 @@
- # Configure settings and install targets
- # FIXME: Copypasted from Ogre and need lots of changes
-
-+include(GNUInstallDirs)
-+
- if (WIN32)
- set(MYGUI_RELEASE_PATH "/Release")
- set(MYGUI_RELWDBG_PATH "/RelWithDebInfo")
-@@ -60,6 +62,12 @@
- # install targets according to current build type
- function(mygui_install_target TARGETNAME SUFFIX)
- install(TARGETS ${TARGETNAME}
-+ RUNTIME DESTINATION "${CMAKE_INSTALL_BINDIR}" CONFIGURATIONS Gentoo ""
-+ LIBRARY DESTINATION "${CMAKE_INSTALL_LIBDIR}" CONFIGURATIONS Gentoo ""
-+ ARCHIVE DESTINATION "${CMAKE_INSTALL_LIBDIR}" CONFIGURATIONS Gentoo ""
-+ FRAMEWORK DESTINATION "${MYGUI_FRAMEWORK_PATH}" CONFIGURATIONS Gentoo ""
-+ )
-+ install(TARGETS ${TARGETNAME}
- RUNTIME DESTINATION "bin${MYGUI_RELEASE_PATH}" CONFIGURATIONS Release None ""
- LIBRARY DESTINATION "lib${MYGUI_LIB_RELEASE_PATH}${SUFFIX}" CONFIGURATIONS Release None ""
- ARCHIVE DESTINATION "lib${MYGUI_LIB_RELEASE_PATH}${SUFFIX}" CONFIGURATIONS Release None ""
-@@ -171,7 +179,13 @@
- endif ()
- add_executable(${PROJECTNAME} ${MYGUI_EXEC_TYPE} ${HEADER_FILES} ${SOURCE_FILES})
- endif ()
-- set_target_properties(${PROJECTNAME} PROPERTIES FOLDER ${SOLUTIONFOLDER})
-+
-+ # rename demo target^M
-+ if (${SOLUTIONFOLDER} STREQUAL "Demos")
-+ set_target_properties(${PROJECTNAME} PROPERTIES FOLDER ${SOLUTIONFOLDER} OUTPUT_NAME MYGUI-${PROJECTNAME})
-+ else()
-+ set_target_properties(${PROJECTNAME} PROPERTIES FOLDER ${SOLUTIONFOLDER})
-+ endif()
-
- add_dependencies(${PROJECTNAME} MyGUIEngine Common)
-
diff --git a/dev-games/mygui/files/mygui-3.2.2-c++17.patch b/dev-games/mygui/files/mygui-3.2.2-c++17.patch
deleted file mode 100644
index 1cdf7babeb12..000000000000
--- a/dev-games/mygui/files/mygui-3.2.2-c++17.patch
+++ /dev/null
@@ -1,27 +0,0 @@
-https://github.com/MyGUI/mygui/commit/ced30dac10082ff9593a2c971d26b3aebce6b2be.patch
-https://bugs.gentoo.org/732778
-
-Part of:
-
-From ced30dac10082ff9593a2c971d26b3aebce6b2be Mon Sep 17 00:00:00 2001
-From: George Evmenov <george.evmenov@geocv.com>
-Date: Fri, 26 Jun 2015 12:25:26 +0300
-Subject: [PATCH] do not use nullptr define
-
---- a/MyGUIEngine/include/MyGUI_Prerequest.h
-+++ b/MyGUIEngine/include/MyGUI_Prerequest.h
-@@ -19,13 +19,7 @@
- #define MYGUI_DEFINE_VERSION(major, minor, patch) ((major << 16) | (minor << 8) | patch)
-
- #ifndef MYGUI_DONT_REPLACE_NULLPTR
--# if MYGUI_COMPILER == MYGUI_COMPILER_MSVC
--# ifndef _MANAGED
--# ifndef _NATIVE_NULLPTR_SUPPORTED
--# define nullptr 0
--# endif
--# endif
--# else
-+# if __cplusplus < 201103L && !defined(_NATIVE_NULLPTR_SUPPORTED)
- # define nullptr 0
- # endif
- #endif
diff --git a/dev-games/mygui/files/mygui-3.2.2-underlinking.patch b/dev-games/mygui/files/mygui-3.2.2-underlinking.patch
deleted file mode 100644
index 2d1026856f03..000000000000
--- a/dev-games/mygui/files/mygui-3.2.2-underlinking.patch
+++ /dev/null
@@ -1,20 +0,0 @@
-From: Julian Ospald <hasufell@gentoo.org>
-Date: Fri Jun 15 10:42:42 UTC 2012
-Subject: build system
-
-fix underlinking
-
---- MyGUIEngine/CMakeLists.txt
-+++ MyGUIEngine/CMakeLists.txt
-@@ -48,7 +48,10 @@
- if (MYGUI_USE_FREETYPE)
- target_link_libraries(${PROJECTNAME}
- ${FREETYPE_LIBRARIES}
-- )
-+ dl)
-+else()
-+ target_link_libraries(${PROJECTNAME}
-+ dl)
- endif()
-
- # platform specific dependencies