summaryrefslogtreecommitdiff
path: root/dev-games/clanlib/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-03-03 10:28:17 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-03-03 10:28:17 +0000
commitd99093fb4bb5652015c06274d64083daa2439e4f (patch)
treecf61513204d97974179580065e85df5c8009087c /dev-games/clanlib/files
parent463397cf1e064185110fe57c568d73f99a06f5d1 (diff)
gentoo resync : 03.03.2021
Diffstat (limited to 'dev-games/clanlib/files')
-rw-r--r--dev-games/clanlib/files/clanlib-0.8.1-docbuilder.patch30
-rw-r--r--dev-games/clanlib/files/clanlib-0.8.1-gcc43.patch8
-rw-r--r--dev-games/clanlib/files/clanlib-0.8.1-libpng15.patch4
-rw-r--r--dev-games/clanlib/files/clanlib-0.8.1-llvm.patch95
-rw-r--r--dev-games/clanlib/files/clanlib-0.8.1-ndebug.patch4
-rw-r--r--dev-games/clanlib/files/clanlib-2.3.7-autotools.patch8
-rw-r--r--dev-games/clanlib/files/clanlib-2.3.7-doc.patch4
-rw-r--r--dev-games/clanlib/files/clanlib-2.3.7-freetype_pkgconfig.patch4
8 files changed, 141 insertions, 16 deletions
diff --git a/dev-games/clanlib/files/clanlib-0.8.1-docbuilder.patch b/dev-games/clanlib/files/clanlib-0.8.1-docbuilder.patch
new file mode 100644
index 000000000000..18752b9e0fbd
--- /dev/null
+++ b/dev-games/clanlib/files/clanlib-0.8.1-docbuilder.patch
@@ -0,0 +1,30 @@
+diff --git a/Documentation/Utilities/webbuilder.pl.in b/Documentation/Utilities/webbuilder.pl.in
+index ea9de63..c000432 100644
+--- a/Documentation/Utilities/webbuilder.pl.in
++++ b/Documentation/Utilities/webbuilder.pl.in
+@@ -68,11 +68,7 @@ sub convert
+ sub print_head
+ {
+ my ($xml_head, $file) = @ARG;
+- my $ml, $buffer;
+-
+- # Don't know what this does, but Perceps does it:
+- if ($*) { $ml=1; }
+- else { $ml=0; }
++ my $buffer;
+
+ # Read theme from disk and execute it:
+ if ( -e $file )
+@@ -93,11 +89,7 @@ sub print_head
+ sub print_body
+ {
+ my ($xml_body, $file) = @ARG;
+- my $ml, $buffer;
+-
+- # Don't know what this does, but Perceps does it:
+- if ($*) { $ml=1; }
+- else { $ml=0; }
++ my $buffer;
+
+ # Read theme from disk and execute it:
+ if ( -e $file )
diff --git a/dev-games/clanlib/files/clanlib-0.8.1-gcc43.patch b/dev-games/clanlib/files/clanlib-0.8.1-gcc43.patch
index ca1d898ce5ab..655e667ff7bf 100644
--- a/dev-games/clanlib/files/clanlib-0.8.1-gcc43.patch
+++ b/dev-games/clanlib/files/clanlib-0.8.1-gcc43.patch
@@ -1,5 +1,5 @@
---- Sources/GL/opengl.cpp
-+++ Sources/GL/opengl.cpp
+--- a/Sources/GL/opengl.cpp
++++ b/Sources/GL/opengl.cpp
@@ -51,6 +51,8 @@
#endif
#endif
@@ -16,8 +16,8 @@
-}
\ No newline at end of file
+}
---- Sources/Network/Socket/ip_address_getsock.cpp
-+++ Sources/Network/Socket/ip_address_getsock.cpp
+--- a/Sources/Network/Socket/ip_address_getsock.cpp
++++ b/Sources/Network/Socket/ip_address_getsock.cpp
@@ -40,6 +40,7 @@
#include "ip_address_getsock.h"
diff --git a/dev-games/clanlib/files/clanlib-0.8.1-libpng15.patch b/dev-games/clanlib/files/clanlib-0.8.1-libpng15.patch
index 03d0ba536acf..81a216f221ad 100644
--- a/dev-games/clanlib/files/clanlib-0.8.1-libpng15.patch
+++ b/dev-games/clanlib/files/clanlib-0.8.1-libpng15.patch
@@ -1,5 +1,5 @@
---- Sources/Display/Providers/png_provider_generic.cpp
-+++ Sources/Display/Providers/png_provider_generic.cpp
+--- a/Sources/Display/Providers/png_provider_generic.cpp
++++ b/Sources/Display/Providers/png_provider_generic.cpp
@@ -107,7 +107,7 @@
png_destroy_read_struct(&png_ptr, &info_ptr, (png_infopp) NULL);
cl_assert(false);
diff --git a/dev-games/clanlib/files/clanlib-0.8.1-llvm.patch b/dev-games/clanlib/files/clanlib-0.8.1-llvm.patch
new file mode 100644
index 000000000000..b1455149a321
--- /dev/null
+++ b/dev-games/clanlib/files/clanlib-0.8.1-llvm.patch
@@ -0,0 +1,95 @@
+diff --git a/Sources/Display/graphic_context.cpp b/Sources/Display/graphic_context.cpp
+index 42545ea..52220e2 100644
+--- a/Sources/Display/graphic_context.cpp
++++ b/Sources/Display/graphic_context.cpp
+@@ -237,18 +237,18 @@ void CL_GraphicContext::fill_triangle(
+ grad.bottom_left.get_alpha()/256.0};
+ */
+ unsigned char color_array[] = {
+- grad.top_left.get_red(),
+- grad.top_left.get_green(),
+- grad.top_left.get_blue(),
+- grad.top_left.get_alpha(),
+- grad.top_right.get_red(),
+- grad.top_right.get_green(),
+- grad.top_right.get_blue(),
+- grad.top_right.get_alpha(),
+- grad.bottom_left.get_red(),
+- grad.bottom_left.get_green(),
+- grad.bottom_left.get_blue(),
+- grad.bottom_left.get_alpha()};
++ static_cast<unsigned char>(grad.top_left.get_red()),
++ static_cast<unsigned char>(grad.top_left.get_green()),
++ static_cast<unsigned char>(grad.top_left.get_blue()),
++ static_cast<unsigned char>(grad.top_left.get_alpha()),
++ static_cast<unsigned char>(grad.top_right.get_red()),
++ static_cast<unsigned char>(grad.top_right.get_green()),
++ static_cast<unsigned char>(grad.top_right.get_blue()),
++ static_cast<unsigned char>(grad.top_right.get_alpha()),
++ static_cast<unsigned char>(grad.bottom_left.get_red()),
++ static_cast<unsigned char>(grad.bottom_left.get_green()),
++ static_cast<unsigned char>(grad.bottom_left.get_blue()),
++ static_cast<unsigned char>(grad.bottom_left.get_alpha())};
+
+ params.count = 1;
+ params.vertices = vertice_array;
+diff --git a/Sources/GL/graphic_context_opengl.cpp b/Sources/GL/graphic_context_opengl.cpp
+index 78bc87d..68da072 100644
+--- a/Sources/GL/graphic_context_opengl.cpp
++++ b/Sources/GL/graphic_context_opengl.cpp
+@@ -355,8 +355,8 @@ void CL_GraphicContext_OpenGL::draw_quad(const CL_Quad &quad, const CL_Color &co
+ state.blendfunc[3] = blend_one_minus_src_alpha;
+ state.fillmode = fillmode_line;
+
+- double qx[4] = { quad.x1, quad.x2, quad.x3, quad.x4 };
+- double qy[4] = { quad.y1, quad.y2, quad.y3, quad.y4 };
++ double qx[4] = { static_cast<double>(quad.x1), static_cast<double>(quad.x2), static_cast<double>(quad.x3), static_cast<double>(quad.x4) };
++ double qy[4] = { static_cast<double>(quad.y1), static_cast<double>(quad.y2), static_cast<double>(quad.y3), static_cast<double>(quad.y4) };
+ int tx[4] = { quad.x1, quad.x2, quad.x3, quad.x4 };
+ int ty[4] = { quad.y1, quad.y2, quad.y3, quad.y4 };
+
+@@ -380,8 +380,8 @@ void CL_GraphicContext_OpenGL::fill_quad(const CL_Quad &quad, const CL_Color &co
+ state.blendfunc[3] = blend_one_minus_src_alpha;
+ state.fillmode = fillmode_solid;
+
+- double qx[4] = { quad.x1, quad.x2, quad.x3, quad.x4 };
+- double qy[4] = { quad.y1, quad.y2, quad.y3, quad.y4 };
++ double qx[4] = { static_cast<double>(quad.x1), static_cast<double>(quad.x2), static_cast<double>(quad.x3), static_cast<double>(quad.x4) };
++ double qy[4] = { static_cast<double>(quad.y1), static_cast<double>(quad.y2), static_cast<double>(quad.y3), static_cast<double>(quad.y4) };
+ int tx[4] = { quad.x1, quad.x2, quad.x3, quad.x4 };
+ int ty[4] = { quad.y1, quad.y2, quad.y3, quad.y4 };
+
+diff --git a/Sources/SDL/graphic_context_sdl.cpp b/Sources/SDL/graphic_context_sdl.cpp
+index 8093e03..c15b399 100644
+--- a/Sources/SDL/graphic_context_sdl.cpp
++++ b/Sources/SDL/graphic_context_sdl.cpp
+@@ -410,7 +410,7 @@ void CL_GraphicContext_SDL::update_cliprect()
+ }
+ else
+ {
+- SDL_Rect crect = {rect.left,rect.top,rect.get_width(),rect.get_height()};
++ SDL_Rect crect = {static_cast<Sint16>(rect.left),static_cast<Sint16>(rect.top),static_cast<Uint16>(rect.get_width()),static_cast<Uint16>(rect.get_height())};
+ SDL_SetClipRect(SDL_GetVideoSurface(),&crect);
+ }
+ }
+diff --git a/Sources/SDL/surface_sdl.cpp b/Sources/SDL/surface_sdl.cpp
+index ff6e36f..532db84 100644
+--- a/Sources/SDL/surface_sdl.cpp
++++ b/Sources/SDL/surface_sdl.cpp
+@@ -259,13 +259,13 @@ void CL_Surface_SDL::draw(
+ CL_Surface_TargetDrawParams1 *t_params1,
+ CL_GraphicContext *context)
+ {
+- SDL_Rect source = {params2.srcX, params2.srcY, params2.srcWidth, params2.srcHeight};
++ SDL_Rect source = {static_cast<Sint16>(params2.srcX), static_cast<Sint16>(params2.srcY), static_cast<Uint16>(params2.srcWidth), static_cast<Uint16>(params2.srcHeight)};
+
+ SDL_Rect dst = {
+ static_cast<Sint16>(t_params1->pixDestX + context->get_modelview().get_origin_x()),
+ static_cast<Sint16>(t_params1->pixDestY + context->get_modelview().get_origin_y()),
+- static_cast<Sint16>(t_params1->destWidth),
+- static_cast<Sint16>(t_params1->destHeight)
++ static_cast<Uint16>(t_params1->destWidth),
++ static_cast<Uint16>(t_params1->destHeight)
+ };
+
+ if (t_params1->destWidth == params2.srcWidth && t_params1->destHeight == params2.srcHeight)
diff --git a/dev-games/clanlib/files/clanlib-0.8.1-ndebug.patch b/dev-games/clanlib/files/clanlib-0.8.1-ndebug.patch
index e41bae1a3296..4a9a4a08582b 100644
--- a/dev-games/clanlib/files/clanlib-0.8.1-ndebug.patch
+++ b/dev-games/clanlib/files/clanlib-0.8.1-ndebug.patch
@@ -9,8 +9,8 @@ This patch adds the missing declaration, thus make the
file compile with or without -DNDEBUG.
diff -Naur clanlib-0.7.8-r2.orig/work/ClanLib-0.7.8/Sources/Core/System/Unix/init_linux.cpp clanlib-0.7.8-r2/work/ClanLib-0.7.8/Sources/Core/System/Unix/init_linux.cpp
---- clanlib-0.7.8-r2.orig/work/ClanLib-0.7.8/Sources/Core/System/Unix/init_linux.cpp 2003-09-19 10:33:02.000000000 +0000
-+++ clanlib-0.7.8-r2/work/ClanLib-0.7.8/Sources/Core/System/Unix/init_linux.cpp 2007-10-26 13:36:39.000000000 +0000
+--- a/Sources/Core/System/Unix/init_linux.cpp 2003-09-19 10:33:02.000000000 +0000
++++ b/Sources/Core/System/Unix/init_linux.cpp 2007-10-26 13:36:39.000000000 +0000
@@ -52,6 +52,7 @@
_begin_time = (long) tv.tv_sec*(long) 1000+(long) tv.tv_usec/(long) 1000;
diff --git a/dev-games/clanlib/files/clanlib-2.3.7-autotools.patch b/dev-games/clanlib/files/clanlib-2.3.7-autotools.patch
index 97db79ac4245..eccc7e291323 100644
--- a/dev-games/clanlib/files/clanlib-2.3.7-autotools.patch
+++ b/dev-games/clanlib/files/clanlib-2.3.7-autotools.patch
@@ -1,5 +1,5 @@
---- Documentation/Reference/Makefile.am.old 2012-09-25 10:39:25.973544935 +0200
-+++ Documentation/Reference/Makefile.am 2012-09-25 10:39:42.560554053 +0200
+--- a/Documentation/Reference/Makefile.am
++++ b/Documentation/Reference/Makefile.am
@@ -10,7 +10,7 @@
mkdir doxyoutput;
mkdir reftest
@@ -9,8 +9,8 @@
../Utilities/ReferenceDocs/ReferenceDocs
install-html:
---- configure.ac.old 2012-09-25 11:07:38.412537590 +0200
-+++ configure.ac 2012-09-25 11:09:41.133939131 +0200
+--- a/configure.ac
++++ b/configure.ac
@@ -337,11 +337,9 @@
dnl Optional linux/joystick.h
diff --git a/dev-games/clanlib/files/clanlib-2.3.7-doc.patch b/dev-games/clanlib/files/clanlib-2.3.7-doc.patch
index 627df26785b4..d207f2df3cca 100644
--- a/dev-games/clanlib/files/clanlib-2.3.7-doc.patch
+++ b/dev-games/clanlib/files/clanlib-2.3.7-doc.patch
@@ -1,5 +1,5 @@
---- Documentation/Utilities/ReferenceDocs/Makefile.old 2014-09-12 20:06:52.970459560 +0200
-+++ Documentation/Utilities/ReferenceDocs/Makefile 2014-09-12 20:08:17.387048685 +0200
+--- a/Documentation/Utilities/ReferenceDocs/Makefile
++++ b/Documentation/Utilities/ReferenceDocs/Makefile
@@ -3,7 +3,10 @@
LIBS=clanCore
EXTRA_LIBS=-lpthread
diff --git a/dev-games/clanlib/files/clanlib-2.3.7-freetype_pkgconfig.patch b/dev-games/clanlib/files/clanlib-2.3.7-freetype_pkgconfig.patch
index 47a1c89b2405..d10a3b0085ad 100644
--- a/dev-games/clanlib/files/clanlib-2.3.7-freetype_pkgconfig.patch
+++ b/dev-games/clanlib/files/clanlib-2.3.7-freetype_pkgconfig.patch
@@ -1,7 +1,7 @@
https://bugs.gentoo.org/764902
---- ClanLib-2.3.7/configure.ac
-+++ ClanLib-2.3.7/configure.ac
+--- a/configure.ac
++++ b/configure.ac
@@ -342,7 +342,7 @@
echo "=============================="
CLANLIB_CHECK_LIB(png, [`cat $srcdir/Setup/Tests/png.cpp`], clanDisplay, [ *** Cannot find png (See http://www.libpng.org ) (Try libpng12-dev or better) ], [-lz -lpng])