summaryrefslogtreecommitdiff
path: root/dev-games/clanlib/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-games/clanlib/files
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-games/clanlib/files')
-rw-r--r--dev-games/clanlib/files/clanlib-0.8.1-gcc43.patch28
-rw-r--r--dev-games/clanlib/files/clanlib-0.8.1-gcc44.patch33
-rw-r--r--dev-games/clanlib/files/clanlib-0.8.1-gcc47.patch10
-rw-r--r--dev-games/clanlib/files/clanlib-0.8.1-gcc6.patch16
-rw-r--r--dev-games/clanlib/files/clanlib-0.8.1-libpng15.patch11
-rw-r--r--dev-games/clanlib/files/clanlib-0.8.1-ndebug.patch21
-rw-r--r--dev-games/clanlib/files/clanlib-2.3.7-autotools.patch45
-rw-r--r--dev-games/clanlib/files/clanlib-2.3.7-doc.patch14
-rw-r--r--dev-games/clanlib/files/clanlib-4.0.0-fix-build-system.patch25
-rw-r--r--dev-games/clanlib/files/clanlib-4.0.0-freetype_pkgconfig.patch27
10 files changed, 230 insertions, 0 deletions
diff --git a/dev-games/clanlib/files/clanlib-0.8.1-gcc43.patch b/dev-games/clanlib/files/clanlib-0.8.1-gcc43.patch
new file mode 100644
index 000000000000..ca1d898ce5ab
--- /dev/null
+++ b/dev-games/clanlib/files/clanlib-0.8.1-gcc43.patch
@@ -0,0 +1,28 @@
+--- Sources/GL/opengl.cpp
++++ Sources/GL/opengl.cpp
+@@ -51,6 +51,8 @@
+ #endif
+ #endif
+
++#include <cstring>
++
+ std::vector<std::string> CL_OpenGL::m_ignored_gl_extension;
+
+ CL_ProcAddress *CL_OpenGL::get_proc_address(const std::string& function_name)
+@@ -414,4 +416,4 @@
+ #endif
+
+ m_ignored_gl_extension.push_back(extension_name);
+-}
+\ No newline at end of file
++}
+--- Sources/Network/Socket/ip_address_getsock.cpp
++++ Sources/Network/Socket/ip_address_getsock.cpp
+@@ -40,6 +40,7 @@
+ #include "ip_address_getsock.h"
+
+ #include <cstdlib>
++#include <cstring>
+
+ #ifndef WIN32
+ #include <sys/socket.h>
diff --git a/dev-games/clanlib/files/clanlib-0.8.1-gcc44.patch b/dev-games/clanlib/files/clanlib-0.8.1-gcc44.patch
new file mode 100644
index 000000000000..ddf5a170b027
--- /dev/null
+++ b/dev-games/clanlib/files/clanlib-0.8.1-gcc44.patch
@@ -0,0 +1,33 @@
+diff -Naur ClanLib-0.8.1-old/Sources/GL/canvas_opengl.cpp ClanLib-0.8.1/Sources/GL/canvas_opengl.cpp
+--- ClanLib-0.8.1-old/Sources/GL/canvas_opengl.cpp 2009-08-01 18:15:44.000000000 +0200
++++ ClanLib-0.8.1/Sources/GL/canvas_opengl.cpp 2009-08-01 18:08:55.000000000 +0200
+@@ -48,6 +48,7 @@
+ #include "graphic_context_opengl.h"
+ #include "surface_target_opengl.h"
+ #include <cstring>
++#include <cstdio>
+
+ /////////////////////////////////////////////////////////////////////////////
+ // CL_Canvas_OpenGL construction:
+diff -Naur ClanLib-0.8.1-old/Sources/GL/GLX/input_device_linuxevent.cpp ClanLib-0.8.1/Sources/GL/GLX/input_device_linuxevent.cpp
+--- ClanLib-0.8.1-old/Sources/GL/GLX/input_device_linuxevent.cpp 2009-08-01 18:17:25.000000000 +0200
++++ ClanLib-0.8.1/Sources/GL/GLX/input_device_linuxevent.cpp 2009-08-01 18:11:23.000000000 +0200
+@@ -35,6 +35,7 @@
+ #include <iostream>
+ #include <errno.h>
+ #include <cstring>
++#include <cstdio>
+
+ #include "API/Core/System/error.h"
+ #include "API/Core/System/clanstring.h"
+diff -Naur ClanLib-0.8.1-old/Sources/GL/GLX/input_device_xinput.cpp ClanLib-0.8.1/Sources/GL/GLX/input_device_xinput.cpp
+--- ClanLib-0.8.1-old/Sources/GL/GLX/input_device_xinput.cpp 2009-08-01 18:17:41.000000000 +0200
++++ ClanLib-0.8.1/Sources/GL/GLX/input_device_xinput.cpp 2009-08-01 18:12:56.000000000 +0200
+@@ -29,6 +29,7 @@
+
+ #include <iostream>
+ #include <cstring>
++#include <cstdio>
+ #include "API/Core/System/log.h"
+ #include "API/Display/input_device.h"
+ #include "API/Display/input_event.h"
diff --git a/dev-games/clanlib/files/clanlib-0.8.1-gcc47.patch b/dev-games/clanlib/files/clanlib-0.8.1-gcc47.patch
new file mode 100644
index 000000000000..19ebab6fd07d
--- /dev/null
+++ b/dev-games/clanlib/files/clanlib-0.8.1-gcc47.patch
@@ -0,0 +1,10 @@
+--- ./Sources/Core/IOData/Generic/inputsource_file.cpp.orig 2012-12-30 01:49:01.698950614 +0400
++++ ./Sources/Core/IOData/Generic/inputsource_file.cpp 2012-12-30 01:49:27.714977456 +0400
+@@ -32,6 +32,7 @@
+ #ifdef WIN32
+ #include <direct.h>
+ #endif
++#include <unistd.h>
+ #include <cstring>
+ #include <API/Core/IOData/inputsource_file.h>
+
diff --git a/dev-games/clanlib/files/clanlib-0.8.1-gcc6.patch b/dev-games/clanlib/files/clanlib-0.8.1-gcc6.patch
new file mode 100644
index 000000000000..95284c2de4ca
--- /dev/null
+++ b/dev-games/clanlib/files/clanlib-0.8.1-gcc6.patch
@@ -0,0 +1,16 @@
+Bug: https://bugs.gentoo.org/596112
+
+--- a/Sources/Core/IOData/Generic/datafile_inputprovider.h
++++ b/Sources/Core/IOData/Generic/datafile_inputprovider.h
+@@ -142,9 +142,9 @@
+ void insert(const std::string &resource_id, int data_pos, int data_size)
+ {
+ cache.insert(
+- std::make_pair<std::string const, std::pair<int, int> >(
++ std::pair<std::string const, std::pair<int, int> >(
+ resource_id,
+- std::make_pair<int,int>(data_pos, data_size)));
++ std::pair<int,int>(data_pos, data_size)));
+ }
+
+ private:
diff --git a/dev-games/clanlib/files/clanlib-0.8.1-libpng15.patch b/dev-games/clanlib/files/clanlib-0.8.1-libpng15.patch
new file mode 100644
index 000000000000..03d0ba536acf
--- /dev/null
+++ b/dev-games/clanlib/files/clanlib-0.8.1-libpng15.patch
@@ -0,0 +1,11 @@
+--- Sources/Display/Providers/png_provider_generic.cpp
++++ Sources/Display/Providers/png_provider_generic.cpp
+@@ -107,7 +107,7 @@
+ png_destroy_read_struct(&png_ptr, &info_ptr, (png_infopp) NULL);
+ cl_assert(false);
+ }
+- if (setjmp(png_ptr->jmpbuf))
++ if (setjmp(png_jmpbuf(png_ptr)))
+ {
+ png_destroy_read_struct(&png_ptr, &info_ptr, &end_info);
+ cl_assert(false);
diff --git a/dev-games/clanlib/files/clanlib-0.8.1-ndebug.patch b/dev-games/clanlib/files/clanlib-0.8.1-ndebug.patch
new file mode 100644
index 000000000000..e41bae1a3296
--- /dev/null
+++ b/dev-games/clanlib/files/clanlib-0.8.1-ndebug.patch
@@ -0,0 +1,21 @@
+Patch for clanlib-0.7.8-r2 Bug 154513:
+
+Signal handler deinit() was not declared.
+
+This leads to a compilation failure when a release version
+rather than a debug version is built (-DNDEBUG).
+
+This patch adds the missing declaration, thus make the
+file compile with or without -DNDEBUG.
+
+diff -Naur clanlib-0.7.8-r2.orig/work/ClanLib-0.7.8/Sources/Core/System/Unix/init_linux.cpp clanlib-0.7.8-r2/work/ClanLib-0.7.8/Sources/Core/System/Unix/init_linux.cpp
+--- clanlib-0.7.8-r2.orig/work/ClanLib-0.7.8/Sources/Core/System/Unix/init_linux.cpp 2003-09-19 10:33:02.000000000 +0000
++++ clanlib-0.7.8-r2/work/ClanLib-0.7.8/Sources/Core/System/Unix/init_linux.cpp 2007-10-26 13:36:39.000000000 +0000
+@@ -52,6 +52,7 @@
+ _begin_time = (long) tv.tv_sec*(long) 1000+(long) tv.tv_usec/(long) 1000;
+
+ #ifdef NDEBUG
++ sighandler_t deinit;
+ signal(SIGSEGV, deinit);
+ #endif
+ }
diff --git a/dev-games/clanlib/files/clanlib-2.3.7-autotools.patch b/dev-games/clanlib/files/clanlib-2.3.7-autotools.patch
new file mode 100644
index 000000000000..97db79ac4245
--- /dev/null
+++ b/dev-games/clanlib/files/clanlib-2.3.7-autotools.patch
@@ -0,0 +1,45 @@
+--- Documentation/Reference/Makefile.am.old 2012-09-25 10:39:25.973544935 +0200
++++ Documentation/Reference/Makefile.am 2012-09-25 10:39:42.560554053 +0200
+@@ -10,7 +10,7 @@
+ mkdir doxyoutput;
+ mkdir reftest
+ doxygen ./clanlib.doxygen
+- make -C ../Utilities/ReferenceDocs
++ $(MAKE) -C ../Utilities/ReferenceDocs
+ ../Utilities/ReferenceDocs/ReferenceDocs
+
+ install-html:
+--- configure.ac.old 2012-09-25 11:07:38.412537590 +0200
++++ configure.ac 2012-09-25 11:09:41.133939131 +0200
+@@ -337,11 +337,9 @@
+
+ dnl Optional linux/joystick.h
+ AC_CHECK_HEADERS(linux/joystick.h, linux_joystick=yes)
+- AM_CONDITIONAL(LINUX_JOYSTICK, test x$linux_joystick = xyes)
+
+ dnl Optional linux/input.h
+ AC_CHECK_HEADERS(linux/input.h, linux_input=yes)
+- AM_CONDITIONAL(LINUX_INPUT, test x$linux_input = xyes)
+
+ if test "$WIN32" = "no" && test "$enable_clanDisplay" != "no"; then
+ CLANLIB_CHECK_LIB(fontconfig, [`cat $srcdir/Setup/Tests/fontconfig.cpp`], clanDisplay, [ *** Cannot find fontconfig (See http://fontconfig.org/ ) (Try libfontconfig1-dev or better) ], [-lfontconfig])
+@@ -358,6 +356,8 @@
+ clanDisplay, [ *** Cannot find version 8 of DirectInput], [-ldxguid -lole32 -ldinput8])
+ fi
+ fi
++AM_CONDITIONAL(LINUX_JOYSTICK, test x$linux_joystick = xyes)
++AM_CONDITIONAL(LINUX_INPUT, test x$linux_input = xyes)
+
+ have_xrender=no
+
+@@ -515,9 +515,9 @@
+ fi
+
+ if test "$enable_clanSound" = "auto"; then enable_clanSound=yes; fi
+- AM_CONDITIONAL(ALSA, test x$have_alsa = xyes)
+
+ fi
++AM_CONDITIONAL(ALSA, test x$have_alsa = xyes)
+
+ if test "$enable_clanSound" != "no"; then
+ enable_clanSound=yes
diff --git a/dev-games/clanlib/files/clanlib-2.3.7-doc.patch b/dev-games/clanlib/files/clanlib-2.3.7-doc.patch
new file mode 100644
index 000000000000..627df26785b4
--- /dev/null
+++ b/dev-games/clanlib/files/clanlib-2.3.7-doc.patch
@@ -0,0 +1,14 @@
+--- Documentation/Utilities/ReferenceDocs/Makefile.old 2014-09-12 20:06:52.970459560 +0200
++++ Documentation/Utilities/ReferenceDocs/Makefile 2014-09-12 20:08:17.387048685 +0200
+@@ -3,7 +3,10 @@
+ LIBS=clanCore
+ EXTRA_LIBS=-lpthread
+
+-include ../../../Examples/Makefile.conf
++CXXFLAGS += -pthread -std=c++0x -I.
++all: $(EXAMPLE_BIN)
++$(EXAMPLE_BIN): $(OBJF)
++ $(CXX) $(CXXFLAGS) $(OBJF) -o $(EXAMPLE_BIN) -Wl,-R../../Sources/Core/.libs -L../../../Sources/Core/.libs -lclan23Core $(EXTRA_LIBS)
+
+ # EOF #
+
diff --git a/dev-games/clanlib/files/clanlib-4.0.0-fix-build-system.patch b/dev-games/clanlib/files/clanlib-4.0.0-fix-build-system.patch
new file mode 100644
index 000000000000..a3500e22f7e1
--- /dev/null
+++ b/dev-games/clanlib/files/clanlib-4.0.0-fix-build-system.patch
@@ -0,0 +1,25 @@
+* Fix AM_CONDITIONAL to always be invoked
+* Install html files in proper --htmldir
+
+--- a/configure.ac
++++ b/configure.ac
+@@ -437,8 +437,8 @@
+ fi
+
+ if test "$enable_clanSound" = "auto"; then enable_clanSound=yes; fi
+- AM_CONDITIONAL(ALSA, test x$have_alsa = xyes)
+ fi
++AM_CONDITIONAL(ALSA, test x$have_alsa = xyes)
+
+ if test "$enable_clanNetwork" != "no"; then
+ echo "Checking for clanNetwork stuff"
+--- a/Documentation/Makefile.am
++++ b/Documentation/Makefile.am
+@@ -1,6 +1,6 @@
+ EXTRA_DIST = $(wildcart images/*.png)
+
+-HTML_PREFIX = $(datadir)/doc/@PACKAGE@-@LT_RELEASE@
++HTML_PREFIX = $(htmldir)
+
+ all-local:
+
diff --git a/dev-games/clanlib/files/clanlib-4.0.0-freetype_pkgconfig.patch b/dev-games/clanlib/files/clanlib-4.0.0-freetype_pkgconfig.patch
new file mode 100644
index 000000000000..34759a8d89d9
--- /dev/null
+++ b/dev-games/clanlib/files/clanlib-4.0.0-freetype_pkgconfig.patch
@@ -0,0 +1,27 @@
+From af16d8a344b9bafc9131508fecfcdbfdc53cf100 Mon Sep 17 00:00:00 2001
+From: Lars Wendler <polynomial-c@gentoo.org>
+Date: Mon, 25 Jun 2018 15:14:31 +0200
+Subject: [PATCH] Use pkg-config to find freetype.
+
+As of freetype-2.9.1 the freetype-config file no longer gets installed
+by default.
+---
+ configure.ac | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/configure.ac b/configure.ac
+index 6b9def916..c97e959f7 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -307,7 +307,7 @@ echo ""
+ if test "$enable_clanDisplay" != "no"; then
+ echo "Checking for clanDisplay stuff"
+ echo "=============================="
+- CLANLIB_CHECK_LIB(ttf, [`cat $srcdir/Setup/Unix/Tests/ttf.cpp`], clanDisplay, [ *** Cannot find ttf (freetype) (See http://freetype.sourceforge.net ) (Try libfreetype6-dev or better) ], [`freetype-config --libs` ], [ `freetype-config --cflags`])
++ CLANLIB_CHECK_LIB(ttf, [`cat $srcdir/Setup/Unix/Tests/ttf.cpp`], clanDisplay, [ *** Cannot find ttf (freetype) (See http://freetype.sourceforge.net ) (Try libfreetype6-dev or better) ], [`pkg-config --libs freetype2` ], [ `pkg-config --cflags freetype2`])
+
+ dnl Optional linux/joystick.h
+ AC_CHECK_HEADERS(linux/joystick.h, has_linux_joystick=yes)
+--
+2.18.0
+