summaryrefslogtreecommitdiff
path: root/dev-games/clanlib/clanlib-0.8.1-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-07-04 08:06:08 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-07-04 08:06:08 +0100
commit2a8d2f71d1d9963368e0ef3d641d75979a689d12 (patch)
tree83e283f960ab2ebbc1a042b8ed6c37b78d47b37b /dev-games/clanlib/clanlib-0.8.1-r2.ebuild
parent8435c842b9e8fbb2bcc80397ab3aa655000459e2 (diff)
gentoo auto-resync : 04:07:2024 - 08:06:07
Diffstat (limited to 'dev-games/clanlib/clanlib-0.8.1-r2.ebuild')
-rw-r--r--dev-games/clanlib/clanlib-0.8.1-r2.ebuild13
1 files changed, 12 insertions, 1 deletions
diff --git a/dev-games/clanlib/clanlib-0.8.1-r2.ebuild b/dev-games/clanlib/clanlib-0.8.1-r2.ebuild
index 4235f050aabd..6cb8b3b5e63e 100644
--- a/dev-games/clanlib/clanlib-0.8.1-r2.ebuild
+++ b/dev-games/clanlib/clanlib-0.8.1-r2.ebuild
@@ -1,8 +1,10 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
+inherit autotools flag-o-matic
+
DESCRIPTION="Multi-platform game development library"
HOMEPAGE="https://github.com/sphair/ClanLib"
SRC_URI="mirror://gentoo/ClanLib-${PV}.tgz"
@@ -48,6 +50,7 @@ PATCHES=(
"${FILESDIR}/${P}-docbuilder.patch"
"${FILESDIR}/${P}-glibc2.34.patch"
"${FILESDIR}/${P}-gcc12.patch"
+ "${FILESDIR}"/${P}-makefile-duplicate-headers.patch
)
DOCS=(
@@ -57,12 +60,20 @@ DOCS=(
src_prepare() {
default
+ eautoreconf
# See #739358
sed -i -e "s:libdir=\${exec_prefix}/lib:libdir=@libdir@:g" \
pkgconfig/*.pc.in || die
}
src_configure() {
+ # -Werror=strict-aliasing
+ # https://bugs.gentoo.org/855308
+ # Fixed in newer versions
+ # Do not trust with LTO either.
+ append-flags -fno-strict-aliasing
+ filter-lto
+
# clanSound only controls mikmod/vorbis so there's
# no need to pass --{en,dis}able-clanSound ...
# clanDisplay only controls X, SDL, OpenGL plugins