summaryrefslogtreecommitdiff
path: root/dev-games/aseprite/aseprite-1.2.40.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-04-12 00:33:29 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-04-12 00:33:29 +0100
commit3a6d209caa07e3be8e8423251b70c8bbeeedb17f (patch)
treeaa94c255fa1bd982214ca518fb93d674cc253101 /dev-games/aseprite/aseprite-1.2.40.ebuild
parent1f43daba2fbe6f53e67c63944941dc645657c5b3 (diff)
gentoo auto-resync : 12:04:2024 - 00:33:28
Diffstat (limited to 'dev-games/aseprite/aseprite-1.2.40.ebuild')
-rw-r--r--dev-games/aseprite/aseprite-1.2.40.ebuild15
1 files changed, 14 insertions, 1 deletions
diff --git a/dev-games/aseprite/aseprite-1.2.40.ebuild b/dev-games/aseprite/aseprite-1.2.40.ebuild
index db187de2e8df..2a603fddfb1f 100644
--- a/dev-games/aseprite/aseprite-1.2.40.ebuild
+++ b/dev-games/aseprite/aseprite-1.2.40.ebuild
@@ -5,7 +5,7 @@ EAPI=8
PYTHON_COMPAT=( python3_{10..12} )
-inherit cmake desktop ninja-utils python-any-r1 toolchain-funcs xdg-utils
+inherit cmake desktop flag-o-matic ninja-utils python-any-r1 toolchain-funcs xdg-utils
SKIA_VER="m102"
# Last commit in ${SKIA_VER} feature branch
@@ -96,6 +96,19 @@ src_prepare() {
}
src_configure() {
+ # -Werror=strict-aliasing, -Werror=odr, -Werror=lto-type-mismatch
+ # https://bugs.gentoo.org/924692
+ # https://github.com/aseprite/aseprite/issues/4413
+ #
+ # There is a bundled skia that fails with ODR errors. When excluding just
+ # skia from testing, aseprite itself fails with strict-aliasing, and when
+ # that is disabled, fails again with ODR and lto-type-mismatch issues.
+ #
+ # There are a lot of issues, so don't trust any fixes without thorough
+ # testing.
+ append-flags -fno-strict-aliasing
+ filter-lto
+
einfo "Skia configuration"
cd "${WORKDIR}/skia-${SKIA_REV}" || die