summaryrefslogtreecommitdiff
path: root/dev-erlang/protobuffs
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-erlang/protobuffs
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-erlang/protobuffs')
-rw-r--r--dev-erlang/protobuffs/Manifest5
-rw-r--r--dev-erlang/protobuffs/metadata.xml11
-rw-r--r--dev-erlang/protobuffs/protobuffs-0.8.2.ebuild39
-rw-r--r--dev-erlang/protobuffs/protobuffs-0.9.0.ebuild39
4 files changed, 94 insertions, 0 deletions
diff --git a/dev-erlang/protobuffs/Manifest b/dev-erlang/protobuffs/Manifest
new file mode 100644
index 000000000000..eba3c91e574d
--- /dev/null
+++ b/dev-erlang/protobuffs/Manifest
@@ -0,0 +1,5 @@
+DIST protobuffs-0.8.2.tar.gz 132660 BLAKE2B a8480b14bfd5007cc8f43218fb669330049c19e5cbad3d8359ed921d0f50e03fea7001c9f901644f3d2ed1868be70576af65aec7d293f0403b058e9e64bd1a3d SHA512 56e9f8d41c500769724adadf025e3915e2b1ab6b68f1664080a49e783facf3d79b5ec20eb8664db9babeea21fc0637c88b1e4a121ca810247e32831a79171b11
+DIST protobuffs-0.9.0.tar.gz 237560 BLAKE2B a29964deae465e0762570a04e6bbe65eea4ab5b60aebf8639724cd7db85716a69d61aa89fbb6dd3464283b1f343dd62f12b8cc2ab6dc0c0e6930d925a4943fbc SHA512 f5838723c5e5ae55f412848978729347186075917893e0b74e5af966ced9f12e8bc65906f3e591c78a99e64d70461df46e5719b83c262e9bbc5acfd1e50ae1d2
+EBUILD protobuffs-0.8.2.ebuild 863 BLAKE2B e59957c9fbcd9b60096643bd61b81a2454ba93970af8cb267cef2160a2b1cb305237beb7a863fda2dbd646915fccd8295f11f93b21c7e6c98534036e06dd3c19 SHA512 e145c7324ed8c549e6136782df7890a65a8ada0cd4d45504798c4a0add915a869782051ed04d9f65cebf93ba5ad0bde6883476ba02cc9b821b298ef0c001f7d6
+EBUILD protobuffs-0.9.0.ebuild 869 BLAKE2B b390e1beac416faf59456ffcfdefbf268d984b559f68846c527da0a205551a76fb3b6f60201a4e4ddf2d4fa206c3785cd394148165728a00e2c617969b92e6ad SHA512 490422a88a470e2d509511fce01aa4c8820b910197c76dee059ba3f3ec8fa6473441f515769995740f7ed1e6a34eaa83747017e707e2addc3cedb14c54d097e5
+MISC metadata.xml 342 BLAKE2B ee493d268783cf1fd1235c044d06e6ca86c6cd1f5b146e9c50dcff64a38b8581afcfa847f424927f3c384bf8990d4586d7bf7ff426f9f718307122fb4e63018e SHA512 860ea904ec9e44a441edebedffed49a0ca8272749434211f01f3dbcfdb642979f52293ebfb91ab4b278f4d1e3e5ba6c478745c07153f8dcfb3e35bb34e102d8a
diff --git a/dev-erlang/protobuffs/metadata.xml b/dev-erlang/protobuffs/metadata.xml
new file mode 100644
index 000000000000..db8497dfce25
--- /dev/null
+++ b/dev-erlang/protobuffs/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>aidecoe@gentoo.org</email>
+ <name>Amadeusz Żołnowski</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">basho/erlang_protobuffs</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-erlang/protobuffs/protobuffs-0.8.2.ebuild b/dev-erlang/protobuffs/protobuffs-0.8.2.ebuild
new file mode 100644
index 000000000000..380ee4f02da5
--- /dev/null
+++ b/dev-erlang/protobuffs/protobuffs-0.8.2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit rebar
+
+MY_PN="erlang_protobuffs"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Google's Protocol Buffers for Erlang"
+HOMEPAGE="https://github.com/basho/erlang_protobuffs"
+SRC_URI="https://github.com/basho/${MY_PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64 ~arm ~ia64 ppc ~sparc x86"
+IUSE="test"
+
+CDEPEND=">=dev-lang/erlang-17.1"
+DEPEND="${CDEPEND}
+ test? (
+ >=dev-erlang/meck-0.8.2
+ >=dev-erlang/proper-1.1
+ )"
+RDEPEND="${CDEPEND}"
+
+DOCS=( AUTHORS ChangeLog README.markdown )
+
+S="${WORKDIR}/${MY_P}"
+
+src_test() {
+ ./scripts/generate_emakefile.escript || die
+ erebar ct
+ # FIXME: 1 test fails, reported upstream:
+ # FIXME: https://github.com/basho/erlang_protobuffs/issues/100
+ # FIXME: erebar eunit
+}
diff --git a/dev-erlang/protobuffs/protobuffs-0.9.0.ebuild b/dev-erlang/protobuffs/protobuffs-0.9.0.ebuild
new file mode 100644
index 000000000000..ba33cf84dd63
--- /dev/null
+++ b/dev-erlang/protobuffs/protobuffs-0.9.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit rebar
+
+MY_PN="erlang_protobuffs"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Google's Protocol Buffers for Erlang"
+HOMEPAGE="https://github.com/basho/erlang_protobuffs"
+SRC_URI="https://github.com/basho/${MY_PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64 ~arm ~ia64 ppc ~sparc x86"
+IUSE="test"
+
+CDEPEND=">=dev-lang/erlang-17.1"
+DEPEND="${CDEPEND}
+ test? (
+ >=dev-erlang/meck-0.8.2
+ >=dev-erlang/proper-1.1
+ )"
+RDEPEND="${CDEPEND}"
+
+DOCS=( AUTHORS ChangeLog README.md RELNOTES.md )
+
+S="${WORKDIR}/${MY_P}"
+
+src_test() {
+ ./scripts/generate_emakefile.escript || die
+ erebar ct
+ # FIXME: 1 test fails, reported upstream:
+ # FIXME: https://github.com/basho/erlang_protobuffs/issues/100
+ # FIXME: erebar eunit
+}