summaryrefslogtreecommitdiff
path: root/dev-erlang/idna/idna-6.0.0-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-06-15 14:57:03 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-06-15 14:57:03 +0100
commitd18bf1e01b65ee4bf0c804e2843b282d3d4e5d7c (patch)
tree4a95cbc6ffdf13bad6ecbc7f8d5af99631984123 /dev-erlang/idna/idna-6.0.0-r1.ebuild
parente748ba9741f6540f4675c23e3e37b73e822c13a4 (diff)
gentoo resync : 15.06.2021
Diffstat (limited to 'dev-erlang/idna/idna-6.0.0-r1.ebuild')
-rw-r--r--dev-erlang/idna/idna-6.0.0-r1.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-erlang/idna/idna-6.0.0-r1.ebuild b/dev-erlang/idna/idna-6.0.0-r1.ebuild
new file mode 100644
index 000000000000..853b273e7c8a
--- /dev/null
+++ b/dev-erlang/idna/idna-6.0.0-r1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit rebar
+
+DESCRIPTION="Erlang IDNA implementation"
+HOMEPAGE="https://github.com/benoitc/erlang-idna"
+SRC_URI="https://github.com/benoitc/erlang-idna/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 ~arm ~ia64 ~ppc ~sparc x86"
+
+DEPEND=">=dev-lang/erlang-21.0"
+
+DOCS=( CHANGELOG README.md )
+
+S="${WORKDIR}/erlang-idna-${PV}"
+
+# Removes dependency to workaround for older erlang versions.
+# Patch based on https://github.com/benoitc/erlang-idna/pull/31
+PATCHES=( "${FILESDIR}/0001-Remove-dependency-on-unicode_util_compat.patch" )