summaryrefslogtreecommitdiff
path: root/dev-erlang/goldrush/goldrush-0.1.9.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-erlang/goldrush/goldrush-0.1.9.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-erlang/goldrush/goldrush-0.1.9.ebuild')
-rw-r--r--dev-erlang/goldrush/goldrush-0.1.9.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-erlang/goldrush/goldrush-0.1.9.ebuild b/dev-erlang/goldrush/goldrush-0.1.9.ebuild
new file mode 100644
index 000000000000..901bcd88f016
--- /dev/null
+++ b/dev-erlang/goldrush/goldrush-0.1.9.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit rebar
+
+DESCRIPTION="Small Erlang app that provides fast event stream processing"
+HOMEPAGE="https://github.com/DeadZen/goldrush"
+SRC_URI="https://github.com/DeadZen/${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ia64 ~ppc ~sparc ~x86"
+
+DEPEND=">=dev-lang/erlang-17.1"
+RDEPEND="${DEPEND}"
+
+DOCS=( README.org )
+
+src_prepare() {
+ rebar_src_prepare
+ # 'priv' directory contains only edoc.css, but doc isn't going to be built.
+ rm -r "${S}/priv" || die
+}