summaryrefslogtreecommitdiff
path: root/dev-erlang/fast_yaml/fast_yaml-1.0.20.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-09-06 10:28:05 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-09-06 10:28:05 +0100
commitf1af93971b7490792d8541bc790e0d8c6d787059 (patch)
treea38046712bbc3a3844d77452d16c84e716caa3d4 /dev-erlang/fast_yaml/fast_yaml-1.0.20.ebuild
parentfc637fb28da700da71ec2064d65ca5a7a31b9c6c (diff)
gentoo resync : 06.08.2019
Diffstat (limited to 'dev-erlang/fast_yaml/fast_yaml-1.0.20.ebuild')
-rw-r--r--dev-erlang/fast_yaml/fast_yaml-1.0.20.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-erlang/fast_yaml/fast_yaml-1.0.20.ebuild b/dev-erlang/fast_yaml/fast_yaml-1.0.20.ebuild
new file mode 100644
index 000000000000..5dfaaa979349
--- /dev/null
+++ b/dev-erlang/fast_yaml/fast_yaml-1.0.20.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit rebar
+
+DESCRIPTION="Fast Yaml native library for Erlang and Elixir"
+HOMEPAGE="https://github.com/processone/fast_yaml"
+SRC_URI="https://github.com/processone/${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ia64 ~ppc ~sparc ~x86"
+
+DEPEND=">=dev-erlang/p1_utils-1.0.16
+ >=dev-lang/erlang-18.0
+ dev-libs/libyaml"
+RDEPEND="${DEPEND}"
+
+DOCS=( CHANGELOG.md README.md )
+
+# from upstream:
+# https://github.com/processone/fast_yaml/commit/e789f68895f71b7ad31057177810ca0161bf790e
+PATCHES=(
+ "${FILESDIR}/${P}-dont-escape-simple-quote.patch"
+)