summaryrefslogtreecommitdiff
path: root/dev-embedded
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-01-10 01:02:07 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-01-10 01:02:07 +0000
commita2219cb0f7891a8fa42ccd9541809c62ce695216 (patch)
tree6261bca3eb2f8c460f2945176ac4eaee444dcdb2 /dev-embedded
parentf03f06fb7152586e3084ebabe54d93f28da8bf6d (diff)
gentoo auto-resync : 10:01:2024 - 01:02:07
Diffstat (limited to 'dev-embedded')
-rw-r--r--dev-embedded/Manifest.gzbin9222 -> 9216 bytes
-rw-r--r--dev-embedded/platformio/Manifest4
-rw-r--r--dev-embedded/platformio/platformio-6.1.11.ebuild (renamed from dev-embedded/platformio/platformio-6.1.6-r2.ebuild)10
3 files changed, 7 insertions, 7 deletions
diff --git a/dev-embedded/Manifest.gz b/dev-embedded/Manifest.gz
index add927dc7c23..f5716fce178d 100644
--- a/dev-embedded/Manifest.gz
+++ b/dev-embedded/Manifest.gz
Binary files differ
diff --git a/dev-embedded/platformio/Manifest b/dev-embedded/platformio/Manifest
index e21a5a040230..90929423f001 100644
--- a/dev-embedded/platformio/Manifest
+++ b/dev-embedded/platformio/Manifest
@@ -1,3 +1,3 @@
-DIST platformio-6.1.6.tar.gz 295288 BLAKE2B 4508f3eda25cbb2d2bad6881d7041a9bd8bb87b452564b3cabd58bec0506ca10e53b2552eee8ac1984cb429e5ea52c332d863f1c76a10b5106ab238e6506bb87 SHA512 879fbc759476118473d13375e4dcdbda901f48f5d0d9bb94bdd3ed09de2563603880b91d102e35eaf144e61cd457b132056e0a8293b762b3566a537f3b886078
-EBUILD platformio-6.1.6-r2.ebuild 3291 BLAKE2B baf33312be1ba3ed163230b6df28bb339ebd379aab136cf06f17778e245ca4a5c0b4870583aa450fa315c9539d92ed841cfe9247bb94e2d5bb1463f31e68ae3e SHA512 73bc1db1cbada42feab649ccf5e8b83c2024b347c40063e1a1d451fb7b91215cfd91ac3e3877ec23a95f3d850102e7553601a7997ed3f977f331b774f01d9af0
+DIST platformio-6.1.11.gh.tar.gz 296333 BLAKE2B 17672b499eca9c828cd7c6ea6a4c8acea7287f42bb78d4fc5fbd11bb93175bb87d9c2d100270869bc99bc0db550b49c163555ddd8edb17b6b33ccc5f3623f768 SHA512 450e3d1dc3b9c8124b6254fbf0a05b207b834aa0661f083ee2915bde5064498b6d5af666ad851b737fa5627ed436db983e038f83ed0437a1e248749a0dcc99ba
+EBUILD platformio-6.1.11.ebuild 3296 BLAKE2B af62046d017c0e1df01fbd8db11faf1289cbf3f7890e4d8905af0f62dcbd4579b551a8ea1b64361080b2e42c0bee4c0a20f6961ef81c4f1f0cbb18fe5b5c6c07 SHA512 b1f93555c92a615d7c59c2d99095beedf72b491f908569dac41c98d9f758629881a75b55c7b24e91114a6ca27ce5eb218f180dffe2c6016eabe540089d29cfa1
MISC metadata.xml 340 BLAKE2B 992fa2488c72523eb663bd6bb85608c3ad39e57781bbf08801ac3d34551fdcebd5b80d50bb4353ceefd5bb2228a56101f8ad2cd155d39cd4ff071d8f664a9f60 SHA512 1a596e7fbfb70e5814dc811ff96f3597f744d3e049ed8cd047238557fbeb1c370f22656990d6e30f42cf9193b899686e85c0edd3d1115af93eb4b7866066dc8c
diff --git a/dev-embedded/platformio/platformio-6.1.6-r2.ebuild b/dev-embedded/platformio/platformio-6.1.11.ebuild
index 5a870f66e445..98da137e5799 100644
--- a/dev-embedded/platformio/platformio-6.1.6-r2.ebuild
+++ b/dev-embedded/platformio/platformio-6.1.11.ebuild
@@ -1,17 +1,17 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
DISTUTILS_SINGLE_IMPL=1
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_COMPAT=( python3_{10..12} )
inherit distutils-r1 udev
DESCRIPTION="An open source ecosystem for IoT development"
HOMEPAGE="https://platformio.org/"
-SRC_URI="https://github.com/platformio/platformio-core/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI="https://github.com/platformio/platformio-core/archive/refs/tags/v${PV}.tar.gz -> ${P}.gh.tar.gz"
S="${WORKDIR}"/${PN}-core-${PV}
LICENSE="BSD"
@@ -29,11 +29,11 @@ RDEPEND="
<dev-python/pyserial-4[${PYTHON_USEDEP}]
>=dev-python/zeroconf-0.37[${PYTHON_USEDEP}]
=dev-python/requests-2*[${PYTHON_USEDEP}]
- >=dev-python/semantic-version-2.9[${PYTHON_USEDEP}]
+ >=dev-python/semantic-version-2.10[${PYTHON_USEDEP}]
<dev-python/semantic-version-3[${PYTHON_USEDEP}]
=dev-python/tabulate-0.9*[${PYTHON_USEDEP}]
dev-python/twisted[${PYTHON_USEDEP}]
- >=dev-python/pyelftools-0.27[${PYTHON_USEDEP}]
+ >=dev-python/pyelftools-0.30[${PYTHON_USEDEP}]
<dev-python/pyelftools-1[${PYTHON_USEDEP}]
=dev-python/marshmallow-3*[${PYTHON_USEDEP}]
>=dev-python/starlette-0.21[${PYTHON_USEDEP}]