summaryrefslogtreecommitdiff
path: root/dev-embedded/sunxi-tools/sunxi-tools-1.3-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
commit40aaaa64e86ba6710bbeb31c4615a6ce80e75e11 (patch)
tree758c221bad35c9288d0bd6df9c7dfc226728e52c /dev-embedded/sunxi-tools/sunxi-tools-1.3-r1.ebuild
parent8d5dbd847cbc704a6a06405856e94b461011afe3 (diff)
gentoo resync : 28.04.2021
Diffstat (limited to 'dev-embedded/sunxi-tools/sunxi-tools-1.3-r1.ebuild')
-rw-r--r--dev-embedded/sunxi-tools/sunxi-tools-1.3-r1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-embedded/sunxi-tools/sunxi-tools-1.3-r1.ebuild b/dev-embedded/sunxi-tools/sunxi-tools-1.3-r1.ebuild
new file mode 100644
index 000000000000..4a73a61da176
--- /dev/null
+++ b/dev-embedded/sunxi-tools/sunxi-tools-1.3-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit toolchain-funcs
+
+MY_PV="v${PV}"
+SRC_URI="https://github.com/linux-sunxi/sunxi-tools/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"
+
+DESCRIPTION="Tools for Allwinner A10 devices."
+HOMEPAGE="http://linux-sunxi.org/"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+KEYWORDS="~amd64"
+
+DEPEND="virtual/libusb"
+
+src_compile() {
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS} -std=c99 -D_POSIX_C_SOURCE=200112L -Iinclude/" all misc
+}
+
+src_install() {
+ dobin bin2fex fex2bin phoenix_info
+ newbin sunxi-bootinfo bootinfo
+ newbin sunxi-fel fel
+ newbin sunxi-fexc fexc
+ newbin sunxi-nand-part nand-part
+ newbin sunxi-pio pio
+}