summaryrefslogtreecommitdiff
path: root/dev-embedded/stm32flash/stm32flash-0.5.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-11-10 00:43:02 +0000
committerV3n3RiX <venerix@redcorelinux.org>2017-11-10 00:43:02 +0000
commita5332b59346f7cbf0fdbd148b54aa8a84aaf8190 (patch)
treee6d8d3589fcd01fbc3f1286185639163daa81424 /dev-embedded/stm32flash/stm32flash-0.5.ebuild
parentfceeaf01a28ee71065cf3798b70b77d3bc4ef199 (diff)
gentoo resync : 10.11.2017
Diffstat (limited to 'dev-embedded/stm32flash/stm32flash-0.5.ebuild')
-rw-r--r--dev-embedded/stm32flash/stm32flash-0.5.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-embedded/stm32flash/stm32flash-0.5.ebuild b/dev-embedded/stm32flash/stm32flash-0.5.ebuild
new file mode 100644
index 000000000000..c1e17f12ab38
--- /dev/null
+++ b/dev-embedded/stm32flash/stm32flash-0.5.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit toolchain-funcs
+
+DESCRIPTION="Open source flash program for STM32 using the ST serial bootloader"
+HOMEPAGE="https://sourceforge.net/projects/stm32flash/"
+SRC_URI="mirror://sourceforge/project/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+S=${WORKDIR}/${PN}
+
+src_prepare() {
+ default
+ tc-export CC
+}
+
+src_install() {
+ dobin ${PN}
+ doman ${PN}.1
+}