summaryrefslogtreecommitdiff
path: root/dev-embedded/stlink/stlink-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
commitd934827bf44b7cfcf6711964418148fa60877668 (patch)
tree0625f358789b5e015e49db139cc1dbc9be00428f /dev-embedded/stlink/stlink-9999.ebuild
parent2e34d110f164bf74d55fced27fe0000201b3eec5 (diff)
gentoo resync : 25.11.2020
Diffstat (limited to 'dev-embedded/stlink/stlink-9999.ebuild')
-rw-r--r--dev-embedded/stlink/stlink-9999.ebuild16
1 files changed, 8 insertions, 8 deletions
diff --git a/dev-embedded/stlink/stlink-9999.ebuild b/dev-embedded/stlink/stlink-9999.ebuild
index 479ca67cd591..0c5402c06feb 100644
--- a/dev-embedded/stlink/stlink-9999.ebuild
+++ b/dev-embedded/stlink/stlink-9999.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="6"
+EAPI=7
-inherit cmake-utils udev
+inherit udev xdg cmake
DESCRIPTION="stm32 discovery line linux programmer"
HOMEPAGE="https://github.com/texane/stlink"
@@ -11,26 +11,26 @@ if [[ ${PV} == "9999" ]]; then
EGIT_REPO_URI="https://github.com/texane/stlink.git"
inherit git-r3
else
- SRC_URI="https://github.com/texane/stlink/archive/${PV}/${P}.tar.gz"
+ SRC_URI="https://github.com/texane/stlink/archive/v${PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64"
fi
LICENSE="BSD"
SLOT="0"
-IUSE=""
RDEPEND="virtual/libusb:1
>=dev-libs/glib-2.32.0:2
x11-libs/gtk+:3"
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
src_configure() {
local mycmakeargs=(
-DSTLINK_UDEV_RULES_DIR="$(get_udevdir)"/rules.d
-DSTLINK_MODPROBED_DIR="${EPREFIX}/etc/modprobe.d"
+ -DSTLINK_STATIC_LIB=OFF
-DLIB_INSTALL_DIR:PATH="$(get_libdir)"
)
- cmake-utils_src_configure
+ cmake_src_configure
}