summaryrefslogtreecommitdiff
path: root/dev-embedded/stlink/stlink-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-embedded/stlink/stlink-9999.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-embedded/stlink/stlink-9999.ebuild')
-rw-r--r--dev-embedded/stlink/stlink-9999.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-embedded/stlink/stlink-9999.ebuild b/dev-embedded/stlink/stlink-9999.ebuild
new file mode 100644
index 000000000000..c7300459c355
--- /dev/null
+++ b/dev-embedded/stlink/stlink-9999.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit cmake-utils udev
+
+DESCRIPTION="stm32 discovery line linux programmer"
+HOMEPAGE="https://github.com/texane/stlink"
+if [[ ${PV} == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/texane/stlink.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/texane/stlink/archive/${PV}/${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="virtual/libusb:1
+ >=dev-libs/glib-2.32.0:2
+ x11-libs/gtk+:3"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_configure() {
+ local mycmakeargs=(
+ -DSTLINK_UDEV_RULES_DIR="$(get_udevdir)"/rules.d
+ -DSTLINK_MODPROBED_DIR="${EPREFIX}/etc/modprobe.d"
+ )
+
+ cmake-utils_src_configure
+}