summaryrefslogtreecommitdiff
path: root/dev-embedded/sgpp-lite-arm-eabi-bin/sgpp-lite-arm-eabi-bin-2010.09.51.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-embedded/sgpp-lite-arm-eabi-bin/sgpp-lite-arm-eabi-bin-2010.09.51.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-embedded/sgpp-lite-arm-eabi-bin/sgpp-lite-arm-eabi-bin-2010.09.51.ebuild')
-rw-r--r--dev-embedded/sgpp-lite-arm-eabi-bin/sgpp-lite-arm-eabi-bin-2010.09.51.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/dev-embedded/sgpp-lite-arm-eabi-bin/sgpp-lite-arm-eabi-bin-2010.09.51.ebuild b/dev-embedded/sgpp-lite-arm-eabi-bin/sgpp-lite-arm-eabi-bin-2010.09.51.ebuild
new file mode 100644
index 000000000000..0bfc753eedb7
--- /dev/null
+++ b/dev-embedded/sgpp-lite-arm-eabi-bin/sgpp-lite-arm-eabi-bin-2010.09.51.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=0
+
+CPU="arm"
+TARGET="arm-none-eabi"
+HOST="i686-pc-linux-gnu"
+MY_P="${CPU}-${PV%.*}-${PV##*.}-${TARGET}-${HOST}"
+
+DESCRIPTION="Regular, validated releases of the GNU Toolchain for ${CPU} processors"
+HOMEPAGE="http://www.codesourcery.com/sgpp/lite/${CPU}"
+SRC_URI="http://www.codesourcery.com/public/gnu_toolchain/${TARGET}/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+RESTRICT="strip" # package is already stripped, and contains target bins
+QA_EXECSTACK="opt/${P}/*"
+
+RDEPEND="sys-libs/glibc"
+DEPEND=""
+
+S=${WORKDIR}/${CPU}-${PV%.*}
+
+src_install() {
+ local d="/opt/${P}"
+ dodir ${d}
+ cp -pPR * "${D}"/${d}/ || die
+
+ pushd "${D}"/${d}/share/doc/${CPU}-${TARGET} >/dev/null
+ if use doc ; then
+ dohtml -r html/* || die
+ dodoc pdf/* || die
+ fi
+ rm -rf html pdf
+ rm LICENSE.txt man/man7/{fsf-funding,gpl,gfdl}.7 || die
+ mv man info ../..
+ popd >/dev/null
+ find "${D}" -depth -type d -empty -delete
+
+ cat <<-EOF > "${T}"/15${P}
+ PATH=${d}/bin
+ MANPATH=${d}/share/man
+ INFOPATH=${d}/share/info
+ EOF
+ doenvd "${T}"/15${P} || die
+}