summaryrefslogtreecommitdiff
path: root/dev-embedded/ponyprog/ponyprog-3.1.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-09-10 04:21:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-09-10 04:21:55 +0100
commit677b7ba5c317778df2ad7e70df94b9b7eec4adbc (patch)
tree6c418a1546fff5becab5d8b9ed6803323e7f316e /dev-embedded/ponyprog/ponyprog-3.1.2.ebuild
parentfbda87924e6faa7a1919f1a2b4182490bde5ec5c (diff)
gentoo resync : 10.09.2021
Diffstat (limited to 'dev-embedded/ponyprog/ponyprog-3.1.2.ebuild')
-rw-r--r--dev-embedded/ponyprog/ponyprog-3.1.2.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-embedded/ponyprog/ponyprog-3.1.2.ebuild b/dev-embedded/ponyprog/ponyprog-3.1.2.ebuild
new file mode 100644
index 000000000000..fd87de76d806
--- /dev/null
+++ b/dev-embedded/ponyprog/ponyprog-3.1.2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="EEPROM and microcontroller programmer/flasher"
+HOMEPAGE="https://github.com/lancos/ponyprog/"
+SRC_URI="https://github.com/lancos/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+DEPEND="
+ >=app-editors/qhexedit2-0.8.6_p20190316
+ dev-embedded/libftdi:1[cxx]
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtmultimedia:5
+ dev-qt/qtprintsupport:5
+ dev-qt/qtwidgets:5
+ virtual/libusb:1
+"
+# blocker on libftdi-1.5-r2: see #775116
+RDEPEND="${DEPEND}
+ !=dev-embedded/libftdi-1.5-r2
+"
+
+PATCHES=( "${FILESDIR}"/${P}-fix-build-system.patch )
+
+pkg_postinst() {
+ elog "To use the COM port in user mode (not as root), you need to"
+ elog "be in the 'uucp' group."
+ elog
+ elog "To use the LPT port in user mode (not as root) you need a kernel with"
+ elog "ppdev, parport and parport_pc compiled in or as modules. You need the"
+ elog "rights to write to /dev/parport? devices."
+}