summaryrefslogtreecommitdiff
path: root/dev-embedded/ponyprog/ponyprog-3.0.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-04-19 14:14:48 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-04-19 14:14:48 +0100
commit5cfef3c94cd7e82136c69a0322f5ba21f7e64632 (patch)
tree8f255dfacbacb657e3ac3654d01c1e11e651c066 /dev-embedded/ponyprog/ponyprog-3.0.0.ebuild
parent8aebb228036d5e2863b7eaa6e319ab41c1669269 (diff)
gentoo resync : 19.04.2018
Diffstat (limited to 'dev-embedded/ponyprog/ponyprog-3.0.0.ebuild')
-rw-r--r--dev-embedded/ponyprog/ponyprog-3.0.0.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-embedded/ponyprog/ponyprog-3.0.0.ebuild b/dev-embedded/ponyprog/ponyprog-3.0.0.ebuild
new file mode 100644
index 000000000000..4c7bfaeb8f8c
--- /dev/null
+++ b/dev-embedded/ponyprog/ponyprog-3.0.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils
+
+DESCRIPTION="EEPROM and microcontroller programmer/flasher"
+HOMEPAGE="https://github.com/lancos/ponyprog/"
+SRC_URI="https://github.com/lancos/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+RDEPEND=">=app-editors/qhexedit2-0.8.4_p20170719
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtmultimedia:5
+ dev-qt/qtprintsupport:5"
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-fix-build-system.patch
+ "${FILESDIR}"/${P}-desktop-qa.patch
+)
+
+src_configure() {
+ local mycmakeargs=( -DCMAKE_INSTALL_DOCDIR="share/doc/${PF}" )
+ cmake-utils_src_configure
+}
+
+pkg_postinst() {
+ elog "To use the COM port in user mode (not as root), you need to"
+ elog "be in the 'uucp' group."
+ elog
+ elog "To use the LPT port in user mode (not as root) you need a kernel with"
+ elog "ppdev, parport and parport_pc compiled in or as modules. You need the"
+ elog "rights to write to /dev/parport? devices."
+}