summaryrefslogtreecommitdiff
path: root/dev-embedded/libftdi/libftdi-1.2-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-12-25 17:37:52 +0000
committerV3n3RiX <venerix@redcorelinux.org>2017-12-25 17:37:52 +0000
commit2f51c9978dda4c6e8debca43e4235ecc86914032 (patch)
treebc41e1c4383040034174c327504f702c8517a123 /dev-embedded/libftdi/libftdi-1.2-r1.ebuild
parent51536d2fe4697ba9114d611178bb9e20d3d5b729 (diff)
gentoo resync : 25.12.2017
Diffstat (limited to 'dev-embedded/libftdi/libftdi-1.2-r1.ebuild')
-rw-r--r--dev-embedded/libftdi/libftdi-1.2-r1.ebuild7
1 files changed, 3 insertions, 4 deletions
diff --git a/dev-embedded/libftdi/libftdi-1.2-r1.ebuild b/dev-embedded/libftdi/libftdi-1.2-r1.ebuild
index 8c4d73cf0ed8..9ca55beeaad6 100644
--- a/dev-embedded/libftdi/libftdi-1.2-r1.ebuild
+++ b/dev-embedded/libftdi/libftdi-1.2-r1.ebuild
@@ -8,8 +8,8 @@ inherit cmake-utils python-single-r1
MY_P="${PN}1-${PV}"
if [[ ${PV} == 9999* ]] ; then
+ inherit git-r3
EGIT_REPO_URI="git://developer.intra2net.com/${PN}"
- inherit git-2
else
SRC_URI="http://www.intra2net.com/en/developer/${PN}/download/${MY_P}.tar.bz2"
KEYWORDS="amd64 arm arm64 ~mips ppc ppc64 sparc x86"
@@ -21,6 +21,7 @@ HOMEPAGE="http://www.intra2net.com/en/developer/libftdi/"
LICENSE="LGPL-2"
SLOT="1"
IUSE="cxx doc examples python static-libs test tools"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
RDEPEND="virtual/libusb:1
cxx? ( dev-libs/boost )
@@ -33,8 +34,6 @@ DEPEND="${RDEPEND}
python? ( dev-lang/swig )
doc? ( app-doc/doxygen )"
-REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
-
pkg_setup() {
use python && python-single-r1_pkg_setup
}
@@ -42,7 +41,7 @@ pkg_setup() {
S=${WORKDIR}/${MY_P}
src_configure() {
- mycmakeargs=(
+ local mycmakeargs=(
-DFTDIPP=$(usex cxx)
-DDOCUMENTATION=$(usex doc)
-DEXAMPLES=$(usex examples)