summaryrefslogtreecommitdiff
path: root/dev-embedded/esptool/esptool-3.3.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-06-11 14:17:10 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-06-11 14:17:10 +0100
commit5adfd733728a4f14df5665f4c2a604a7356e5f19 (patch)
treef2938c4a08576b45508b02481edfec55eac3ac8b /dev-embedded/esptool/esptool-3.3.2.ebuild
parentfbba40085f5d1591a67b49f5aa48b4071b7560f1 (diff)
gentoo auto-resync : 11:06:2023 - 14:17:09
Diffstat (limited to 'dev-embedded/esptool/esptool-3.3.2.ebuild')
-rw-r--r--dev-embedded/esptool/esptool-3.3.2.ebuild47
1 files changed, 0 insertions, 47 deletions
diff --git a/dev-embedded/esptool/esptool-3.3.2.ebuild b/dev-embedded/esptool/esptool-3.3.2.ebuild
deleted file mode 100644
index 477fc8cac266..000000000000
--- a/dev-embedded/esptool/esptool-3.3.2.ebuild
+++ /dev/null
@@ -1,47 +0,0 @@
-# Copyright 2021-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{9..11} )
-DISTUTILS_USE_PEP517=setuptools
-DISTUTILS_SINGLE_IMPL=1
-
-inherit distutils-r1
-
-DESCRIPTION="Utility to communicate with the ROM bootloader in Espressif ESP8266 and ESP32"
-HOMEPAGE="https://github.com/espressif/esptool"
-SRC_URI="https://github.com/espressif/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="GPL-2+"
-SLOT="0"
-KEYWORDS="amd64 ~arm ~arm64 x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- $(python_gen_cond_dep '
- dev-python/bitstring[${PYTHON_USEDEP}]
- dev-python/cryptography[${PYTHON_USEDEP}]
- >=dev-python/ecdsa-0.16.0[${PYTHON_USEDEP}]
- dev-python/pyserial[${PYTHON_USEDEP}]
- dev-python/reedsolomon[${PYTHON_USEDEP}]
- ')
-"
-BDEPEND="
- $(python_gen_cond_dep '
- dev-python/wheel[${PYTHON_USEDEP}]
- ')
- test? ( $(python_gen_cond_dep '
- dev-python/coverage[${PYTHON_USEDEP}]
- dev-python/pyelftools[${PYTHON_USEDEP}]
- ') )
-"
-
-python_test() {
- "${EPYTHON}" test/test_imagegen.py || die "imagegen test failed with ${EPYTHON}"
- "${EPYTHON}" test/test_espsecure.py || die "espsecure test failed with ${EPYTHON}"
- "${EPYTHON}" test/test_espefuse_host.py || die "espefuse_host test failed with ${EPYTHON}"
- "${EPYTHON}" test/test_merge_bin.py || die "espefuse_host test failed with ${EPYTHON}"
- # test/test_esptool.py and test/test_espefuse.py need real hardware connected
-}