summaryrefslogtreecommitdiff
path: root/dev-embedded/esptool/esptool-3.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-11-28 20:40:51 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-11-28 20:40:51 +0000
commit9c417bacd51da6d8b57fa9f37425161d30d4b95b (patch)
tree47c9d6e4243f39a1f48afd54c969b65b00a5c649 /dev-embedded/esptool/esptool-3.0.ebuild
parentd934827bf44b7cfcf6711964418148fa60877668 (diff)
gentoo resync : 28.11.2020
Diffstat (limited to 'dev-embedded/esptool/esptool-3.0.ebuild')
-rw-r--r--dev-embedded/esptool/esptool-3.0.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-embedded/esptool/esptool-3.0.ebuild b/dev-embedded/esptool/esptool-3.0.ebuild
new file mode 100644
index 000000000000..d66949a64efa
--- /dev/null
+++ b/dev-embedded/esptool/esptool-3.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} )
+DISTUTILS_SINGLE_IMPL=1
+
+inherit distutils-r1
+
+DESCRIPTION="Utility to communicate with the ROM bootloader in Espressif ESP8266 and ESP32"
+HOMEPAGE="https://github.com/espressif/esptool"
+SRC_URI="https://github.com/espressif/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ $(python_gen_cond_dep '
+ dev-python/bitstring[${PYTHON_MULTI_USEDEP}]
+ dev-python/cryptography[${PYTHON_MULTI_USEDEP}]
+ >=dev-python/ecdsa-0.16.0[${PYTHON_MULTI_USEDEP}]
+ dev-python/pyserial[${PYTHON_MULTI_USEDEP}]
+ dev-python/reedsolomon[${PYTHON_MULTI_USEDEP}]
+ ')
+"
+BDEPEND="
+ test? ( $(python_gen_cond_dep 'dev-python/pyelftools[${PYTHON_MULTI_USEDEP}]') )
+"
+
+python_test() {
+ ${EPYTHON} test/test_imagegen.py || die "imagegen test failed with ${EPYTHON}"
+ ${EPYTHON} test/test_espsecure.py || die "espsecure test failed with ${EPYTHON}"
+ ${EPYTHON} test/test_espefuse_host.py || die "espefuse_host test failed with ${EPYTHON}"
+ # test/test_esptool.py and test/test_espefuse.py need real hardware connected
+}