summaryrefslogtreecommitdiff
path: root/dev-embedded/esptool/esptool-2.8.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-02-13 21:41:11 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-02-13 21:41:11 +0000
commitc8d60dada2ec8eb48b2d2b290cd6683ccec40e39 (patch)
treec44943ee0563a3fa957716de909fed683117fcb9 /dev-embedded/esptool/esptool-2.8.ebuild
parent69051588e2f955485fe5d45d45e616bc60a2de57 (diff)
gentoo (valentine's day) resync : 14.02.2021
Diffstat (limited to 'dev-embedded/esptool/esptool-2.8.ebuild')
-rw-r--r--dev-embedded/esptool/esptool-2.8.ebuild37
1 files changed, 0 insertions, 37 deletions
diff --git a/dev-embedded/esptool/esptool-2.8.ebuild b/dev-embedded/esptool/esptool-2.8.ebuild
deleted file mode 100644
index 5bcb03d5fe71..000000000000
--- a/dev-embedded/esptool/esptool-2.8.ebuild
+++ /dev/null
@@ -1,37 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_7 )
-
-inherit distutils-r1
-
-DESCRIPTION="Utility to communicate with the ROM bootloader in Espressif ESP8266 and ESP32"
-HOMEPAGE="https://github.com/espressif/esptool"
-SRC_URI="https://github.com/espressif/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="GPL-2+"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
-
-RDEPEND="
- dev-python/ecdsa[${PYTHON_USEDEP}]
- dev-python/pyaes[${PYTHON_USEDEP}]
- >=dev-python/pyserial-3.0[${PYTHON_USEDEP}]
-"
-
-DEPEND="
- test? ( ${RDEPEND}
- dev-python/pyelftools[${PYTHON_USEDEP}]
- )
-"
-
-python_test() {
- ${EPYTHON} test/test_imagegen.py || die "imagegen test failed with ${EPYTHON}"
- ${EPYTHON} test/test_espsecure.py || die "espsecure test failed with ${EPYTHON}"
-}