summaryrefslogtreecommitdiff
path: root/dev-embedded/esptool/esptool-2.8-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
commitd934827bf44b7cfcf6711964418148fa60877668 (patch)
tree0625f358789b5e015e49db139cc1dbc9be00428f /dev-embedded/esptool/esptool-2.8-r1.ebuild
parent2e34d110f164bf74d55fced27fe0000201b3eec5 (diff)
gentoo resync : 25.11.2020
Diffstat (limited to 'dev-embedded/esptool/esptool-2.8-r1.ebuild')
-rw-r--r--dev-embedded/esptool/esptool-2.8-r1.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-embedded/esptool/esptool-2.8-r1.ebuild b/dev-embedded/esptool/esptool-2.8-r1.ebuild
new file mode 100644
index 000000000000..3c6a1359415f
--- /dev/null
+++ b/dev-embedded/esptool/esptool-2.8-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8,9} ) # apps work with 3_9 but test depend is not fulfilled
+DISTUTILS_SINGLE_IMPL=1
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+DESCRIPTION="Utility to communicate with the ROM bootloader in Espressif ESP8266 and ESP32"
+HOMEPAGE="https://github.com/espressif/esptool"
+SRC_URI="https://github.com/espressif/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ $(python_gen_cond_dep '
+ dev-python/ecdsa[${PYTHON_MULTI_USEDEP}]
+ dev-python/pyaes[${PYTHON_MULTI_USEDEP}]
+ >=dev-python/pyserial-3.0[${PYTHON_MULTI_USEDEP}]
+ ')
+"
+BDEPEND="
+ test? ( $(python_gen_cond_dep 'dev-python/pyelftools[${PYTHON_MULTI_USEDEP}]') )
+"
+
+src_prepare() {
+ rm -rf pyaes/ ecdsa/ || die "unable to remove bundled modules"
+ default
+}
+
+python_test() {
+ ${EPYTHON} test/test_imagegen.py || die "imagegen test failed with ${EPYTHON}"
+ ${EPYTHON} test/test_espsecure.py || die "espsecure test failed with ${EPYTHON}"
+}