summaryrefslogtreecommitdiff
path: root/dev-embedded/esptool/esptool-2.6.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
commitdeba8115d2c2af26df42966b91ef04ff4dd79cde (patch)
tree9a48f42594e1a9e6b2020d5535a784314434d7a7 /dev-embedded/esptool/esptool-2.6.ebuild
parent38423c67c8a23f6a1bc42038193182e2da3116eb (diff)
gentoo resync : 14.05.2020
Diffstat (limited to 'dev-embedded/esptool/esptool-2.6.ebuild')
-rw-r--r--dev-embedded/esptool/esptool-2.6.ebuild37
1 files changed, 0 insertions, 37 deletions
diff --git a/dev-embedded/esptool/esptool-2.6.ebuild b/dev-embedded/esptool/esptool-2.6.ebuild
deleted file mode 100644
index 3b0512e262a6..000000000000
--- a/dev-embedded/esptool/esptool-2.6.ebuild
+++ /dev/null
@@ -1,37 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_6 )
-
-inherit distutils-r1
-
-DESCRIPTION="Utility to communicate with the ROM bootloader in Espressif ESP8266 and ESP32"
-HOMEPAGE="https://github.com/espressif/esptool"
-SRC_URI="https://github.com/espressif/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="GPL-2+"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
-
-RDEPEND="
- dev-python/ecdsa[${PYTHON_USEDEP}]
- dev-python/pyaes[${PYTHON_USEDEP}]
- >=dev-python/pyserial-3.0[${PYTHON_USEDEP}]
-"
-
-DEPEND="
- test? ( ${RDEPEND}
- dev-python/pyelftools[${PYTHON_USEDEP}]
- )
-"
-
-python_test() {
- ${EPYTHON} test/test_imagegen.py || die "imagegen test failed with ${EPYTHON}"
- ${EPYTHON} test/test_espsecure.py || die "espsecure test failed with ${EPYTHON}"
-}