summaryrefslogtreecommitdiff
path: root/dev-embedded/avra/avra-1.4.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-03-03 13:42:34 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-03-03 13:42:34 +0000
commit066d27181e9a797ad9f8fc43b49fc9a10ff2f707 (patch)
tree3cb05783d73b2c33589ba305144a31c718e123cd /dev-embedded/avra/avra-1.4.0.ebuild
parent16449a80e28af2209916cc66d19c9a44ca2b90d9 (diff)
gentoo resync : 03.03.2019
Diffstat (limited to 'dev-embedded/avra/avra-1.4.0.ebuild')
-rw-r--r--dev-embedded/avra/avra-1.4.0.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/dev-embedded/avra/avra-1.4.0.ebuild b/dev-embedded/avra/avra-1.4.0.ebuild
new file mode 100644
index 000000000000..be6fdfe16542
--- /dev/null
+++ b/dev-embedded/avra/avra-1.4.0.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Atmel AVR Assembler"
+HOMEPAGE="https://github.com/hsoft/avra"
+SRC_URI="https://github.com/hsoft/avra/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+src_compile() {
+ emake PREFIX=/usr CFLAGS="${CFLAGS} \$(CDEFS)" LDFLAGS="${LDFLAGS}"
+}
+
+src_install() {
+ emake PREFIX=/usr DESTDIR="${ED}" install
+ dodoc {AUTHORS,CHANGELOG.md,README.md,USAGE.md}
+}