summaryrefslogtreecommitdiff
path: root/dev-dotnet
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-01-30 23:49:25 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-01-30 23:49:25 +0000
commitfdc0e69ff470f51130dba7c7a539210ceedf9e6d (patch)
treec17533ac33965d5b150997aa149cb1c35ad777d6 /dev-dotnet
parent28d8acbb30a9ebda81447e5e3f5210a438ba7d24 (diff)
gentoo auto-resync : 30:01:2024 - 23:49:25
Diffstat (limited to 'dev-dotnet')
-rw-r--r--dev-dotnet/Manifest.gzbin4296 -> 4296 bytes
-rw-r--r--dev-dotnet/fable/Manifest2
-rw-r--r--dev-dotnet/fable/fable-4.9.0.ebuild9
3 files changed, 9 insertions, 2 deletions
diff --git a/dev-dotnet/Manifest.gz b/dev-dotnet/Manifest.gz
index d9b7a33a003b..e89205494f08 100644
--- a/dev-dotnet/Manifest.gz
+++ b/dev-dotnet/Manifest.gz
Binary files differ
diff --git a/dev-dotnet/fable/Manifest b/dev-dotnet/fable/Manifest
index 1640cbee2b04..2e9e256e107f 100644
--- a/dev-dotnet/fable/Manifest
+++ b/dev-dotnet/fable/Manifest
@@ -260,5 +260,5 @@ DIST xunit.core.2.5.2.nupkg 31027 BLAKE2B abfc5ae7dfc247fc89d6c83a79e0020e83e0bd
DIST xunit.extensibility.core.2.5.2.nupkg 276559 BLAKE2B a368f8d02cee0eea62b5dc7ccfcf1a5c6d872701d47e4534b52cce414c2c2b7493234f90c5ec16f29fcb516d12509220d4a63352f0af8b306a69730f8de301e3 SHA512 c8a9722381fcf48800042dbde628dca6a3fc761650a37bc561b0404e29f292f011de0636c0cced3f9ae57fc8fc4bb421fc4af231c14c35665b4eba906ed3a95a
DIST xunit.extensibility.execution.2.5.2.nupkg 360168 BLAKE2B 860ecb433be1051c19056ca84d4749c39c3eebfaac6bc2ce7280e7ca3e0224c302de72595cf7b39607a4495236be26085450982100af1fb0ca5c2ea827bcf0ef SHA512 80357981f14ff3b0e8f341ef316f0fb43151ae5e6147b0196020a8644ee9ecc4044953a48f436b5a03661dc3c545397c8072194c9938f59d3abce0b0f24c6506
DIST xunit.runner.visualstudio.2.5.3.nupkg 572634 BLAKE2B 56b7a777c824de661b90832f221a71960489b4815083cbd433dd63136914fdbb9fb3481558e497925ad3a1feaa440832f398fc1b7f0e07e59e73ec0c1c35d199 SHA512 4433134fc4a10e371202c38977834c3937326f06146d198c5996c07b6d796d51b25b85c5b4c6415a3859603f3c2a8221b21d5a23cdb5f7a805ca1b66b7262045
-EBUILD fable-4.9.0.ebuild 10006 BLAKE2B 11d2b85948aa9bab7a6856f1168d45073b0432d38407d9bda38b53fbceb46cb308dd02125bb4e818f5c56a26fa10260e298d44065eedca843ee190fa925b1606 SHA512 41824e8a339a3475c88b7326711a87fd17871830af4a4546a31ec11e56907cff5065e8c8629cef3e815091b057791f865eebc23c44ce7b34f173a833aaeb5a5f
+EBUILD fable-4.9.0.ebuild 10181 BLAKE2B 49fdcd155d2ca5c91fe75d8e70f2e44dae9c4876fce6a9b255f3bee780e69ea24564e98ce864f1ef1d3097ed4849cc06e5db2908a7367c397c93340a820f6447 SHA512 65ce4deda4056322ecb08ced8785d14e2f3f662398157fca9bc51a106f83419edf709ecfb3fadbd62fa957f0aea748c281ded89a7acea7edee34160b83405627
MISC metadata.xml 615 BLAKE2B 9d25df11215f987833b54f525cf50cc61c03d716545929d2d8380de98b34b8e3fff379bfac9220576a2d89a6e4a05d9d4e4a3c2c3ff2daf3b170c502bd7d2b7a SHA512 8c644b9c67ba562029985d1fcea99656a1d2a92c436affdea98c72bb4f1426529098247b7fecf311cd608e6e4b9b4a44e772d4264f775674eb7e4efe51926711
diff --git a/dev-dotnet/fable/fable-4.9.0.ebuild b/dev-dotnet/fable/fable-4.9.0.ebuild
index a36d9e9e9072..e564ab360793 100644
--- a/dev-dotnet/fable/fable-4.9.0.ebuild
+++ b/dev-dotnet/fable/fable-4.9.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -318,6 +318,13 @@ src_unpack() {
src_prepare() {
rm Fable.Standalone.sln || die
+ if use debug ; then
+ DOTNET_PKG_REMOVE_PROJECTS+=(
+ # Seems to hang but in reality it fails with USE=debug, bug #922684
+ tests/Python/Fable.Tests.Python.fsproj
+ )
+ fi
+
dotnet-pkg_src_prepare
edotnet sln ./Fable.sln remove "${DOTNET_PKG_REMOVE_PROJECTS[@]}"
}