summaryrefslogtreecommitdiff
path: root/dev-dotnet/pe-format/pe-format-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-dotnet/pe-format/pe-format-9999.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-dotnet/pe-format/pe-format-9999.ebuild')
-rw-r--r--dev-dotnet/pe-format/pe-format-9999.ebuild54
1 files changed, 54 insertions, 0 deletions
diff --git a/dev-dotnet/pe-format/pe-format-9999.ebuild b/dev-dotnet/pe-format/pe-format-9999.ebuild
new file mode 100644
index 000000000000..e9f8305fd6ce
--- /dev/null
+++ b/dev-dotnet/pe-format/pe-format-9999.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+#if LIVE
+EGIT_REPO_URI="https://bitbucket.org/mgorny/${PN}2.git"
+
+inherit autotools git-r3
+#endif
+
+inherit systemd xdg-utils
+
+DESCRIPTION="Intelligent PE executable wrapper for binfmt_misc"
+HOMEPAGE="https://bitbucket.org/mgorny/pe-format2/"
+SRC_URI="https://www.bitbucket.org/mgorny/${PN}2/downloads/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND="dev-util/desktop-file-utils"
+RDEPEND="!<sys-apps/openrc-0.9.4"
+
+#if LIVE
+KEYWORDS=
+SRC_URI=
+
+src_prepare() {
+ default
+ eautoreconf
+}
+#endif
+
+src_configure() {
+ local myconf=(
+ --with-systemdsystemunitdir="$(systemd_get_systemunitdir)"
+ )
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+ keepdir /var/lib
+}
+
+pkg_postinst() {
+ ebegin "Calling pe-format2-setup to update handler setup"
+ pe-format2-setup
+ eend ${?}
+
+ xdg_desktop_database_update
+}