summaryrefslogtreecommitdiff
path: root/dev-dotnet/libgdiplus
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
commit40aaaa64e86ba6710bbeb31c4615a6ce80e75e11 (patch)
tree758c221bad35c9288d0bd6df9c7dfc226728e52c /dev-dotnet/libgdiplus
parent8d5dbd847cbc704a6a06405856e94b461011afe3 (diff)
gentoo resync : 28.04.2021
Diffstat (limited to 'dev-dotnet/libgdiplus')
-rw-r--r--dev-dotnet/libgdiplus/Manifest3
-rw-r--r--dev-dotnet/libgdiplus/libgdiplus-6.0.2-r1.ebuild60
-rw-r--r--dev-dotnet/libgdiplus/libgdiplus-6.0.2.ebuild4
3 files changed, 64 insertions, 3 deletions
diff --git a/dev-dotnet/libgdiplus/Manifest b/dev-dotnet/libgdiplus/Manifest
index 6d46aeee844b..2e8805577683 100644
--- a/dev-dotnet/libgdiplus/Manifest
+++ b/dev-dotnet/libgdiplus/Manifest
@@ -1,3 +1,4 @@
DIST libgdiplus-6.0.2.tar.gz 1377140 BLAKE2B 5c639a14371eadee0bfa2ad135284089c65212bde0909d21af8f80fd5bdf7283a8aa688ed88df374a0eac0696a377ba05419b12d9a93b37550c020d2b9961ee0 SHA512 b334846cf9471e6f81a3e0a2d6b68c9a39f52e6b22833432e34d3823ae12e3aa9d481806ea9a078463a77f56f3265633447d6709c5ade86ea117d3690f16472c
-EBUILD libgdiplus-6.0.2.ebuild 1127 BLAKE2B 9f689bf4c9f9fc1a9c1f18811fb741d9ed441198833ca00fe918debda348f10ddbfef49eb9a57edfe311c297de9dad31088bd628ebdaa4298f79385eb99e407d SHA512 8fbfec1da6ccd9ecdf2ea67b313f49a12715606898568b3a162fd2de8a0786a13608af887ab0695233717912f243a3a3294f2f61003b0c7b6dd84e4732026d1a
+EBUILD libgdiplus-6.0.2-r1.ebuild 1417 BLAKE2B 6c3c66e220174c9915491fa9aeb26727c6d1ec5375ee508a8b5cc1397a0c56f55415f534b6fef956d5755fa3b49513a0d80574ffed7b0218cdeffafee82b9d6b SHA512 3e03de23d55b8338b2f976de6d417e9c50faac8c2ad9b2a96c4ff09e96f09eba5c762be57723ef339737738102b1a4704164aa32f780d0a1e4c1b6f00071c8da
+EBUILD libgdiplus-6.0.2.ebuild 1120 BLAKE2B 25a178b1d5d9c2919132be4b832a03bbd97a9b7325a891cc51ae2b33d1383ced2218ac7a8a0f7d3a4ac860f1e6eb06285fe110ad7c6aa07b940d322a63f19008 SHA512 6161a2954110267dda61ae62360aedcb0eecbf7fb45f418ab27338008a6a5511a6dcf1c6a788712e3ae18c98d953e26b7882cceb24e846b51f72bf56a4b4dfed
MISC metadata.xml 255 BLAKE2B 495c21dcece437a54ddf2ba6c003601ac84e8ff4f4dd814be0cdae9bb3b6d81ce49f3b00f47ad9ca73f1c9a8b11ed9addaa3c5b8352857813e76d994d020292f SHA512 2ad078558aba9045a782316fc558ea3c6edf579a77a87c0096e3a85ac78a73904a5ceb48cec15ed30fafacc79a66fcf6836acac43d311d1840ccdd62fc2a6896
diff --git a/dev-dotnet/libgdiplus/libgdiplus-6.0.2-r1.ebuild b/dev-dotnet/libgdiplus/libgdiplus-6.0.2-r1.ebuild
new file mode 100644
index 000000000000..6de35495da5d
--- /dev/null
+++ b/dev-dotnet/libgdiplus/libgdiplus-6.0.2-r1.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools eutils dotnet
+
+DESCRIPTION="Library for using System.Drawing with Mono"
+HOMEPAGE="https://www.mono-project.com"
+SRC_URI="https://download.mono-project.com/sources/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE="cairo"
+#skip tests due https://bugs.gentoo.org/687784
+RESTRICT="test"
+
+RDEPEND="dev-libs/glib
+ media-libs/freetype
+ media-libs/fontconfig
+ >=media-libs/giflib-5.1.2
+ media-libs/libexif
+ media-libs/libpng:0=
+ media-libs/tiff
+ x11-libs/cairo[X]
+ x11-libs/libX11
+ x11-libs/libXrender
+ x11-libs/libXt
+ virtual/jpeg:0
+ !cairo? ( x11-libs/pango )"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ default
+ # Don't default to pango when `--with-pango` is not given.
+ # Link against correct pango libraries. Bug #700280
+ sed -e 's/text_v=default/text_v=cairo/' \
+ -e 's/pangocairo/pangocairo pangoft2/' \
+ -i configure.ac || die
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --disable-static \
+ $(usex cairo "" "--with-pango")
+}
+
+src_install() {
+ default
+
+ dotnet_multilib_comply
+ local commondoc=( AUTHORS ChangeLog README TODO )
+ for docfile in "${commondoc[@]}"; do
+ [[ -e "${docfile}" ]] && dodoc "${docfile}"
+ done
+ [[ "${DOCS[@]}" ]] && dodoc "${DOCS[@]}"
+ find "${ED}" -name '*.la' -delete || die
+}
diff --git a/dev-dotnet/libgdiplus/libgdiplus-6.0.2.ebuild b/dev-dotnet/libgdiplus/libgdiplus-6.0.2.ebuild
index 652c18ce18cc..756e7f296da6 100644
--- a/dev-dotnet/libgdiplus/libgdiplus-6.0.2.ebuild
+++ b/dev-dotnet/libgdiplus/libgdiplus-6.0.2.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-inherit eutils dotnet ltprune
+inherit dotnet ltprune
DESCRIPTION="Library for using System.Drawing with Mono"
HOMEPAGE="https://www.mono-project.com"