summaryrefslogtreecommitdiff
path: root/dev-dotnet/dotnet-runtime-nugets/dotnet-runtime-nugets-6.0.12.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-11-26 04:33:49 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-11-26 04:33:49 +0000
commitc5ca18eee76dfed87e06ea7b99017878b77d4d24 (patch)
treedf2095871315f80372e3ed1f2c19d8549e0b1570 /dev-dotnet/dotnet-runtime-nugets/dotnet-runtime-nugets-6.0.12.ebuild
parent4dc9bfa1f12673bbf1343e64af7e0cd715534a9f (diff)
gentoo auto-resync : 26:11:2023 - 04:33:49
Diffstat (limited to 'dev-dotnet/dotnet-runtime-nugets/dotnet-runtime-nugets-6.0.12.ebuild')
-rw-r--r--dev-dotnet/dotnet-runtime-nugets/dotnet-runtime-nugets-6.0.12.ebuild59
1 files changed, 0 insertions, 59 deletions
diff --git a/dev-dotnet/dotnet-runtime-nugets/dotnet-runtime-nugets-6.0.12.ebuild b/dev-dotnet/dotnet-runtime-nugets/dotnet-runtime-nugets-6.0.12.ebuild
deleted file mode 100644
index 26590c583b5b..000000000000
--- a/dev-dotnet/dotnet-runtime-nugets/dotnet-runtime-nugets-6.0.12.ebuild
+++ /dev/null
@@ -1,59 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DOTNET_PKG_COMPAT=$(ver_cut 1-2)
-NUGETS="
-microsoft.aspnetcore.app.ref@${PV}
-microsoft.aspnetcore.app.runtime.linux-arm@${PV}
-microsoft.aspnetcore.app.runtime.linux-arm64@${PV}
-microsoft.aspnetcore.app.runtime.linux-musl-arm@${PV}
-microsoft.aspnetcore.app.runtime.linux-musl-arm64@${PV}
-microsoft.aspnetcore.app.runtime.linux-musl-x64@${PV}
-microsoft.aspnetcore.app.runtime.linux-x64@${PV}
-microsoft.netcore.app.host.linux-arm@${PV}
-microsoft.netcore.app.host.linux-arm64@${PV}
-microsoft.netcore.app.host.linux-musl-arm@${PV}
-microsoft.netcore.app.host.linux-musl-arm64@${PV}
-microsoft.netcore.app.host.linux-musl-x64@${PV}
-microsoft.netcore.app.host.linux-x64@${PV}
-microsoft.netcore.app.ref@${PV}
-microsoft.netcore.app.runtime.linux-arm@${PV}
-microsoft.netcore.app.runtime.linux-arm64@${PV}
-microsoft.netcore.app.runtime.linux-musl-arm@${PV}
-microsoft.netcore.app.runtime.linux-musl-arm64@${PV}
-microsoft.netcore.app.runtime.linux-musl-x64@${PV}
-microsoft.netcore.app.runtime.linux-x64@${PV}
-"
-
-inherit dotnet-pkg-base
-
-DESCRIPTION=".NET runtime nugets"
-HOMEPAGE="https://dotnet.microsoft.com/"
-SRC_URI="${NUGET_URIS}"
-S="${WORKDIR}"
-
-LICENSE="MIT"
-SLOT="${PV}/${PV}"
-KEYWORDS="amd64 arm arm64"
-
-src_unpack() {
- :
-}
-
-src_install() {
- nuget_donuget "${DISTDIR}/microsoft.aspnetcore.app.ref.${PV}.nupkg"
- nuget_donuget "${DISTDIR}/microsoft.netcore.app.ref.${PV}.nupkg"
-
- local runtime=$(dotnet-pkg-base_get-runtime)
- local -a nuget_namespaces=(
- microsoft.aspnetcore.app.runtime
- microsoft.netcore.app.host
- microsoft.netcore.app.runtime
- )
- local nuget_namespace
- for nuget_namespace in "${nuget_namespaces[@]}" ; do
- nuget_donuget "${DISTDIR}/${nuget_namespace}.${runtime}.${PV}.nupkg"
- done
-}