summaryrefslogtreecommitdiff
path: root/dev-dotnet/csharp-gentoodotnetinfo/csharp-gentoodotnetinfo-1.1.1-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-12-17 20:58:02 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-12-17 20:58:02 +0000
commit3a38a5d9da46eca9d656aa0ec448c8ba6034b044 (patch)
tree82664350bc7b90a6468e096087e6b4204e772ca7 /dev-dotnet/csharp-gentoodotnetinfo/csharp-gentoodotnetinfo-1.1.1-r1.ebuild
parent5959c8510d12e770f9320c71e55b4419e49154ee (diff)
gentoo auto-resync : 17:12:2023 - 20:58:01
Diffstat (limited to 'dev-dotnet/csharp-gentoodotnetinfo/csharp-gentoodotnetinfo-1.1.1-r1.ebuild')
-rw-r--r--dev-dotnet/csharp-gentoodotnetinfo/csharp-gentoodotnetinfo-1.1.1-r1.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/dev-dotnet/csharp-gentoodotnetinfo/csharp-gentoodotnetinfo-1.1.1-r1.ebuild b/dev-dotnet/csharp-gentoodotnetinfo/csharp-gentoodotnetinfo-1.1.1-r1.ebuild
new file mode 100644
index 000000000000..45af3fc4d63e
--- /dev/null
+++ b/dev-dotnet/csharp-gentoodotnetinfo/csharp-gentoodotnetinfo-1.1.1-r1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DOTNET_PKG_COMPAT=8.0
+NUGETS="
+microsoft.dotnet.platformabstractions@3.1.6
+system.commandline@2.0.0-beta4.22272.1
+"
+
+inherit dotnet-pkg
+
+DESCRIPTION=".NET information tool for Gentoo"
+HOMEPAGE="https://gitlab.gentoo.org/dotnet/csharp-gentoodotnetinfo/"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://gitlab.gentoo.org/dotnet/${PN}.git"
+else
+ SRC_URI="https://gitlab.gentoo.org/dotnet/${PN}/-/archive/${PV}/${P}.tar.bz2"
+
+ KEYWORDS="amd64 ~arm ~arm64"
+fi
+
+SRC_URI+=" ${NUGET_URIS} "
+
+LICENSE="GPL-2+"
+SLOT="0"
+
+DOTNET_PKG_PROJECTS=(
+ Source/v1/gentoo-dotnet-info-app/GentooDotnetInfo/GentooDotnetInfo.csproj
+)
+
+src_unpack() {
+ dotnet-pkg_src_unpack
+
+ if [[ -n "${EGIT_REPO_URI}" ]] ; then
+ git-r3_src_unpack
+ fi
+}
+
+src_install() {
+ local launcher_dll="/usr/share/${P}/GentooDotnetInfo.dll"
+
+ dotnet-pkg-base_install
+ dotnet-pkg-base_dolauncher_portable "${launcher_dll}" gentoo-dotnet-info
+
+ einstalldocs
+}