summaryrefslogtreecommitdiff
path: root/dev-debug
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-05-16 00:01:30 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-05-16 00:01:30 +0100
commit66113e7871aede225d661473925cea4cce9e6d23 (patch)
tree5bca10c8eeb5527fc3625567fc296a60dd9695cd /dev-debug
parent514c44bb9cc421df9c323acbad430cbb6ee5b89a (diff)
gentoo auto-resync : 16:05:2024 - 00:01:30
Diffstat (limited to 'dev-debug')
-rw-r--r--dev-debug/Manifest.gzbin4016 -> 4017 bytes
-rw-r--r--dev-debug/systemtap/Manifest1
-rw-r--r--dev-debug/systemtap/systemtap-5.0-r1.ebuild136
3 files changed, 137 insertions, 0 deletions
diff --git a/dev-debug/Manifest.gz b/dev-debug/Manifest.gz
index ea80d14f34e5..c09fc333b79c 100644
--- a/dev-debug/Manifest.gz
+++ b/dev-debug/Manifest.gz
Binary files differ
diff --git a/dev-debug/systemtap/Manifest b/dev-debug/systemtap/Manifest
index bf05f4403d16..6966e6e78175 100644
--- a/dev-debug/systemtap/Manifest
+++ b/dev-debug/systemtap/Manifest
@@ -4,5 +4,6 @@ DIST systemtap-4.9.tar.gz 6684228 BLAKE2B 880747bcfbaa1909ca20a6cb30eb37d9443547
DIST systemtap-5.0.tar.gz 6572411 BLAKE2B db962df2fdcbc5bc11259c03d78073924f03fee4434dca8686a62fcb0818dab1ca91558160dd9d67d43b709f63ffe4f0af30ab1fe6965e19155bdd4c04501a04 SHA512 dc511a05e66abcbbd8c926973962751196180f3c571d0cd2a3b158ae367c5339ad32967a680ecd03224ab5f7ed2c55be7064867e4fb1b1cd7ea1cb21b2436e4c
EBUILD systemtap-4.8.ebuild 3289 BLAKE2B da64029050587f4c0f8549cc4c14926395ceab9eafb45a8469cbf7aed45374715e59bfaa9425912217ac380243155a925fb448ab9ccd4904b91bb7145332cf5f SHA512 512eef09c40a2970fece747d19a99a685085781ae636e2d0424076542a115912b4b2700d8a571ce80a25cb19c9e7dfc9bdeeba7d962aebbf73c5f73db7661462
EBUILD systemtap-4.9.ebuild 3331 BLAKE2B d7e750989c55b671540d46e59156a1446ca7feb545bb1d4b5c72be22cdf1a7ee8348056c5dd6db6f0baa1ce76bdf159e7566f95bbb8774d1ba47d11bf5fa23f3 SHA512 fd4ec545a29cd056ce86e65b98d17d92ff763a381401a538e2dcd5a6848e68b532c62138df20db3a7d133b9fb36ce6a7e821cb22a774a95bd74db23e1cd5017f
+EBUILD systemtap-5.0-r1.ebuild 3777 BLAKE2B 0d614c38fd0bff9e49ec1f38d0ab66905701b01dd7ec4bafc5d592f1c5399437affb2c0403f2517c7c722f7b087e451b482a9fab476ee9cc357cb8c4a4210241 SHA512 b3219929a05189468df110ab6f0307ab9b1d0ff0309cfdeced7db5b8e95468af85e1b19f3c5d4afd77402d374e9063119ab6be183d111fafae65e1036de40aae
EBUILD systemtap-5.0.ebuild 3343 BLAKE2B 482238459cf2ee6043b8771734082f1ce4e0ba68979c77869782a795c6ff16d284cafc259c49028f2ef07c7ed8a8ea780172b619037c6763b513b92dc7c20310 SHA512 973460c157d1f3337b63e8ae27c3c78a60da347313cbc75f881d132dd41ef8b5c30828a7a62ae0f7d7f8e7d3359b6df88298da4de685d1421fa1666e7b93eb59
MISC metadata.xml 303 BLAKE2B 5db95d500a08d656d0221a474d297c8357712f19334f45db347e36f14a10365d65777e0d24c68f75d4855b3ee1778dca1ecf4a05b19d2dd3975acf25a12b4523 SHA512 27261bc875c881495a9b0e1fffc811dff40b763a9e6453ca47143cb8d7d867682becd7266f8d559ad8c32bb5d7de9698341055d483f3e6a68b107895aa174b77
diff --git a/dev-debug/systemtap/systemtap-5.0-r1.ebuild b/dev-debug/systemtap/systemtap-5.0-r1.ebuild
new file mode 100644
index 000000000000..cbd73ebe1f15
--- /dev/null
+++ b/dev-debug/systemtap/systemtap-5.0-r1.ebuild
@@ -0,0 +1,136 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..11} pypy3 )
+
+inherit autotools linux-info python-single-r1
+
+DESCRIPTION="A linux trace/probe tool"
+HOMEPAGE="https://www.sourceware.org/systemtap"
+SRC_URI="https://www.sourceware.org/ftp/${PN}/releases/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE="libvirt selinux sqlite +ssl test zeroconf"
+
+CDEPEND="
+ ${PYTHON_DEPS}
+
+ dev-libs/boost:=
+ >=dev-libs/elfutils-0.142[debuginfod]
+ dev-libs/json-c:=
+ sys-libs/ncurses:=
+ sys-libs/readline:=
+
+ libvirt? ( >=app-emulation/libvirt-1.0.2 )
+ selinux? ( sys-libs/libselinux )
+ sqlite? ( dev-db/sqlite:3 )
+ ssl? (
+ dev-libs/nspr
+ dev-libs/nss
+ )
+ zeroconf? ( net-dns/avahi )
+"
+DEPEND="
+ ${CDEPEND}
+ app-alternatives/cpio
+ app-text/xmlto
+ $(python_gen_cond_dep 'dev-python/setuptools[${PYTHON_USEDEP}]')
+ >=sys-devel/gettext-0.18.2
+
+ libvirt? ( dev-libs/libxml2 )
+"
+RDEPEND="
+ ${CDEPEND}
+ acct-group/stapdev
+ acct-group/stapsys
+ acct-group/stapusr
+"
+BDEPEND="test? ( dev-util/dejagnu )"
+
+CONFIG_CHECK="~KPROBES ~RELAY ~DEBUG_FS"
+ERROR_KPROBES="${PN} requires support for KProbes Instrumentation (KPROBES) - this can be enabled in 'Instrumentation Support -> Kprobes'."
+ERROR_RELAY="${PN} works with support for user space relay support (RELAY) - this can be enabled in 'General setup -> Kernel->user space relay support (formerly relayfs)'."
+ERROR_DEBUG_FS="${PN} works best with support for Debug Filesystem (DEBUG_FS) - this can be enabled in 'Kernel hacking -> Debug Filesystem'."
+
+DOCS="AUTHORS HACKING NEWS README"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+RESTRICT="!test? ( test )"
+PATCHES=(
+ "${FILESDIR}/${PN}-3.1-ia64.patch"
+)
+
+pkg_setup() {
+ linux-info_pkg_setup
+ python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ python_fix_shebang .
+
+ sed -i \
+ -e 's|-Werror||g' \
+ configure.ac \
+ Makefile.am \
+ stapbpf/Makefile.am \
+ stapdyn/Makefile.am \
+ staprun/Makefile.am \
+ testsuite/systemtap.unprivileged/unprivileged_probes.exp \
+ testsuite/systemtap.unprivileged/unprivileged_myproc.exp \
+ testsuite/systemtap.base/stmt_rel_user.exp \
+ testsuite/systemtap.base/sdt_va_args.exp \
+ testsuite/systemtap.base/sdt_misc.exp \
+ testsuite/systemtap.base/sdt.exp \
+ scripts/kprobes_test/gen_code.py \
+ || die "Failed to clean up sources"
+
+ sed -i \
+ -e 's#$(INSTALL_DATA) $(srcdir)/stap-exporter.options "$(DESTDIR)$(sysconfdir)/sysconfig/stap-exporter"##g' \
+ stap-exporter/Makefile.am || die "Failed to modify stap-exporter Makefile.am"
+ sed -i \
+ -e '\#^EnvironmentFile=-/etc/sysconfig/stap-exporter#d' \
+ -e 's#$PORT $KEEPALIVE $SCRIPTS $OPTIONS#--port 9900 --keepalive 300#g' \
+ stap-exporter/stap-exporter.service || die "Failed to adapt stap-exporter.service"
+
+ default
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ --cache-file="${S}"/config.cache
+ --disable-docs
+ --disable-grapher
+ --disable-refdocs
+ --disable-server
+ # Our toolchain sets this for us already and adding in
+ # -D_FORTIFY_SOURCE=2 breaks builds w/ no optimisation.
+ # This option (at least as of 4.5) doesn't pass -fno* etc,
+ # it just doesn't _add_ options, which is good. If it changes
+ # to actually pass -fno-stack-protector and friends, we'll
+ # need to change course. Forcing =2 also has problems for
+ # setting it to 3.
+ # bug #794667.
+ --disable-ssp
+ --enable-pie
+ --with-python3
+ --without-java
+ --without-openssl
+ --without-python2-probes
+ --without-rpm
+ $(use_enable libvirt virt)
+ $(use_enable sqlite)
+ $(use_with zeroconf avahi)
+ $(use_with ssl nss)
+ $(use_with selinux)
+ )
+ PYTHON3="${PYTHON}" econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+ python_optimize
+}