summaryrefslogtreecommitdiff
path: root/dev-debug/lldb/lldb-16.0.6.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-03-08 01:07:00 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-03-08 01:07:00 +0000
commit443cfbefc0bbd1e252d323db7597b33ace434817 (patch)
treeaeab1cdb4ddfa5340339e11ffa04b2513377d7e7 /dev-debug/lldb/lldb-16.0.6.ebuild
parent4c5e0520b3ae5cce70461c3f7fceb313186d6ea2 (diff)
gentoo auto-resync : 08:03:2024 - 01:06:59
Diffstat (limited to 'dev-debug/lldb/lldb-16.0.6.ebuild')
-rw-r--r--dev-debug/lldb/lldb-16.0.6.ebuild5
1 files changed, 4 insertions, 1 deletions
diff --git a/dev-debug/lldb/lldb-16.0.6.ebuild b/dev-debug/lldb/lldb-16.0.6.ebuild
index 3ba34e51a3a7..aab1e8475662 100644
--- a/dev-debug/lldb/lldb-16.0.6.ebuild
+++ b/dev-debug/lldb/lldb-16.0.6.ebuild
@@ -4,7 +4,7 @@
EAPI=8
PYTHON_COMPAT=( python3_{10..12} )
-inherit cmake llvm llvm.org python-single-r1
+inherit cmake flag-o-matic llvm llvm.org python-single-r1
DESCRIPTION="The LLVM debugger"
HOMEPAGE="https://llvm.org/"
@@ -60,6 +60,9 @@ pkg_setup() {
}
src_configure() {
+ # bug #858389 (https://github.com/llvm/llvm-project/issues/83636)
+ filter-lto
+
# LLVM_ENABLE_ASSERTIONS=NO does not guarantee this for us, #614844
use debug || local -x CPPFLAGS="${CPPFLAGS} -DNDEBUG"