summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-04-26 23:59:37 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-04-26 23:59:37 +0100
commit3e42d1577189af123b773dc0f11e5419035308c8 (patch)
tree95d77507c924544b12363e6da6aa741c444f3e8a /dev-db
parent6243676c91946098c06d42bc87b5eb99aac40bf0 (diff)
gentoo auto-resync : 26:04:2024 - 23:59:36
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/Manifest.gzbin16607 -> 16613 bytes
-rw-r--r--dev-db/mycli/Manifest2
-rw-r--r--dev-db/mycli/mycli-1.27.2.ebuild76
3 files changed, 78 insertions, 0 deletions
diff --git a/dev-db/Manifest.gz b/dev-db/Manifest.gz
index 4a87e757ae36..b84dc3bc3aa4 100644
--- a/dev-db/Manifest.gz
+++ b/dev-db/Manifest.gz
Binary files differ
diff --git a/dev-db/mycli/Manifest b/dev-db/mycli/Manifest
index d1832c926bc9..5ecc0d130849 100644
--- a/dev-db/mycli/Manifest
+++ b/dev-db/mycli/Manifest
@@ -1,4 +1,6 @@
AUX mycli-1.21.1-fix-test-install.patch 456 BLAKE2B 3f4eafe405a2151b1b2897ac60347a5fdce45747f927a40367943ad78ef96753ad106bdefe516b76946fa509b17a31d9423cf0b5cf311e79174ce5e4f6320428 SHA512 90c53b12baee1339cdc629615a021ff0290e6350f3358491cd163c4405d49be02340a56a73475623a6b49877cef53e3c5bd9aa93897aa91769a402e8f4c0b88a
DIST mycli-1.27.0.gh.tar.gz 285739 BLAKE2B 9b3ba8b98289721774d7bf06465402440d70772ee4f456f1a14a02a0f0cf90e6c4e6fe2abe36436ea051042bed208868dc469e9ef7c4499a9fdacd519b119199 SHA512 ae6fa9ed9151a39988ea64c5d551a68c92014cbaae4ec6695a727cd008882298d3373d1992768eff0781e881738f72f00dfe4756196c0ba82009758b1ea16b51
+DIST mycli-1.27.2.gh.tar.gz 286537 BLAKE2B 7bff978f9a08561c33f5327f13b8b69226e5c735527a607190a3c5d75f091b9f76b8d432e7a3e315ff250995e0baea7f7e0bede17e0b1cc6654939b7ec82b0ae SHA512 fdf0342b0e850b5232c815e73f44f22c7ea162201588681ccf2f4107b84b87f01fff3999a9720fef454239192356f074f47642ddc760af18973a2aaaac4676cd
EBUILD mycli-1.27.0.ebuild 2257 BLAKE2B b2a71b6346533c2a67b51e049f67f7836ebc243c17629a5e4441f66219e8a8f310bde23b877911e01b70ae00133a8497113647df67aff71081e84d25106ec7f5 SHA512 ca70768bab70d103fb89f77aca060866d0ddd73809d3fa61ab0ceae7445f0fb8ef849fbbbe1cd8fe9c0bf67ca3bc232e140ace9fd45e92a8da907d66e3db0b5a
+EBUILD mycli-1.27.2.ebuild 1965 BLAKE2B e9e2eee903dd6ff7ea763901ced695724ddfe707950882f095f5a057219dbf1b1e63b21cee0717d44580613aae60a24fac87b9e54541ebae2854ab7f53caca40 SHA512 276048144af05d33c7a2333e4d30ceb9100038e7f156219e3e68e6405fdddedb0ec2b11cff1a9d1b2fb7b64901410f7a4410cdfaa00ad1d7ff28693435e57d5f
MISC metadata.xml 626 BLAKE2B 754538c528392717c6f22b1988d8d901458eaa053d90fdcc6a96c30408a6f9e661bbd8da4dfd57e8edc71e715028e493d7c3b3994ae7b337556881294c771095 SHA512 1d08dd18cdc6e1ab95e80b5234ed6f64c6b9f69346c86bde183c8bbee1940fd54c6a958b03e9b142dceb6d7e61eae2d47c3c5012a9e368a4ec6617c7539729d5
diff --git a/dev-db/mycli/mycli-1.27.2.ebuild b/dev-db/mycli/mycli-1.27.2.ebuild
new file mode 100644
index 000000000000..445b7b84997e
--- /dev/null
+++ b/dev-db/mycli/mycli-1.27.2.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_SINGLE_IMPL=yes
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="CLI for MySQL Database with auto-completion and syntax highlighting"
+HOMEPAGE="
+ https://www.mycli.net/
+ https://github.com/dbcli/mycli/
+ https://pypi.org/project/mycli/
+"
+SRC_URI="
+ https://github.com/dbcli/mycli/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="ssh"
+
+RDEPEND="
+ $(python_gen_cond_dep '
+ >=dev-python/cli-helpers-2.2.1[${PYTHON_USEDEP}]
+ >=dev-python/click-7.0[${PYTHON_USEDEP}]
+ >=dev-python/configobj-5.0.5[${PYTHON_USEDEP}]
+ >=dev-python/cryptography-1.0.0[${PYTHON_USEDEP}]
+ >=dev-python/prompt-toolkit-3.0.6[${PYTHON_USEDEP}]
+ <dev-python/prompt-toolkit-4.0.0[${PYTHON_USEDEP}]
+ >=dev-python/pyaes-1.6.1[${PYTHON_USEDEP}]
+ >=dev-python/pygments-1.6[${PYTHON_USEDEP}]
+ >=dev-python/pymysql-0.9.2[${PYTHON_USEDEP}]
+ >=dev-python/pyperclip-1.8.1[${PYTHON_USEDEP}]
+ >=dev-python/sqlglot-5.1.3[${PYTHON_USEDEP}]
+ >=dev-python/sqlparse-0.3.0[${PYTHON_USEDEP}]
+ ssh? ( dev-python/paramiko[${PYTHON_USEDEP}] )
+ ')
+"
+BDEPEND="
+ test? (
+ $(python_gen_cond_dep '
+ dev-python/paramiko[${PYTHON_USEDEP}]
+ ')
+ )
+"
+
+EPYTEST_DESELECT=(
+ # Requires a running mysql daemon
+ "test/test_main.py::test_batch"
+ "test/test_main.py::test_execute"
+ "test/test_main.py::test_init"
+ "test/test_special_iocommands.py::test_favorite_query"
+ "test/test_special_iocommands.py::test_watch"
+ "test/test_tabular_output.py::test_sql_output"
+)
+
+EPYTEST_IGNORE=(
+ # Requires a running mysql daemon
+ "test/test_sqlexecute.py"
+)
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ default
+
+ # Relax sqlparse requirement, 0.5.0 didn't have major API changes that would necessitate this restriction.
+ # bug #930690
+ sed -i -e '/sqlparse/ s/,<0.5.0//' setup.py || die
+}