summaryrefslogtreecommitdiff
path: root/dev-db/unixODBC
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-09-16 09:32:48 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-09-16 09:32:48 +0100
commit9ee6d97c2883d42f204a533a8bc1f4562df778fb (patch)
treeb690ddc0ca30f1472887edbb0b8313629bfcbbb2 /dev-db/unixODBC
parentb17a3ef12038de50228bade1f05502c74e135321 (diff)
gentoo resync : 16.09.2020
Diffstat (limited to 'dev-db/unixODBC')
-rw-r--r--dev-db/unixODBC/Manifest2
-rw-r--r--dev-db/unixODBC/unixODBC-2.3.9.ebuild62
2 files changed, 64 insertions, 0 deletions
diff --git a/dev-db/unixODBC/Manifest b/dev-db/unixODBC/Manifest
index 830b9073d73e..fcc24fa26d71 100644
--- a/dev-db/unixODBC/Manifest
+++ b/dev-db/unixODBC/Manifest
@@ -1,3 +1,5 @@
DIST unixODBC-2.3.7.tar.gz 1669501 BLAKE2B 0e6b2130b72ccfed3a26877ff1c8af9adc7cc514002d3198d5249a12da5de03322178bf0847b92336b5a373893751bf3cb5aec4c251163a3c9f0ef98c90e5db8 SHA512 a87afeaaa0476f4ae6345c7021b3af52718944e599abb595c864d9126744a21341889802512a1de3ebaf86ac89e7f8b1bbd7f8f5285e8f4bccf928bd1585ff70
+DIST unixODBC-2.3.9.tar.gz 1676145 BLAKE2B f4078f9266cea753b6f78d234290efe95a6fa9551088a6ce352b0b6ac5391bf2724f872dcc2df0368e98befd24f995ab4eb6958a34bb080b0f6d08993991a0b7 SHA512 6637eab751401522e0af775cb104cd07693b82927453a98e5af28e079f4b9f40e1cfab8cb36f509c46dced89b45244bc5ed1a3dda17ba5a52a844e8e82f187bb
EBUILD unixODBC-2.3.7.ebuild 1752 BLAKE2B e82a6a3037cdf7568aafa03e5d8c1792af8ea94213b7658eb23e5680ffeb79e5ba834ec7a928a535727625a736c3826203013fcd90f0e1a2db65193bab95311b SHA512 ca30504d325086e1d8093cac9f44163cb2c77a17a85e4e3d0365566d0646f457fd02f8836217f23d1dc7b3fe3e52c31d84c3f2d65e16da073c589bd6e6cd9072
+EBUILD unixODBC-2.3.9.ebuild 1790 BLAKE2B ff148bf207c061573cca90ccedb24bcabc339944e3a1b39584d7fb71b234c85c0bb529643d251c14b5aba4327abb67a970b5fb8d141cbb7d8e5f963c48ebff50 SHA512 f4ac8fe154552f24471fbe8e5364a2d5cf4065d6b802f51f7a44b64abfce066ccbf02ed870dbaf6b66928d094eac470e7f14c44340d6d78efefd4454c3d6d80b
MISC metadata.xml 393 BLAKE2B aae8c823c6e3d1a3b21910c6aece373e66e62c6686b152f1f6c8fb980a4c58b19dce1144afb76219d4d4e451ee097afe0f031130e82cbf933e6ac1ba3d4f1cc5 SHA512 76f899e62d86b476cc9f97daffe5c67fba8fe217fb0d6c0b1b39f2de8e6a92350e6d0433f37f54f57875d3cbb3be7908eaa9a3b1717fc1da687a1789062c0f86
diff --git a/dev-db/unixODBC/unixODBC-2.3.9.ebuild b/dev-db/unixODBC/unixODBC-2.3.9.ebuild
new file mode 100644
index 000000000000..62e28e4b316c
--- /dev/null
+++ b/dev-db/unixODBC/unixODBC-2.3.9.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit libtool multilib-minimal
+
+DESCRIPTION="A complete ODBC driver manager"
+HOMEPAGE="http://www.unixodbc.org/"
+SRC_URI="ftp://ftp.unixodbc.org/pub/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="+minimal odbcmanual static-libs unicode"
+
+RDEPEND="
+ || (
+ dev-libs/libltdl:0[${MULTILIB_USEDEP}]
+ >=sys-devel/libtool-2.4.2-r1[${MULTILIB_USEDEP}]
+ )
+ >=sys-libs/readline-6.2_p5-r1:0=[${MULTILIB_USEDEP}]
+ >=sys-libs/ncurses-5.9-r3:0=[${MULTILIB_USEDEP}]
+ >=virtual/libiconv-0-r1[${MULTILIB_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ sys-devel/flex
+"
+
+MULTILIB_CHOST_TOOLS=( /usr/bin/odbc_config )
+MULTILIB_WRAPPED_HEADERS=( /usr/include/unixodbc_conf.h )
+
+multilib_src_configure() {
+ # --enable-driver-conf is --enable-driverc as per configure.in
+ myeconfargs=(
+ --sysconfdir="${EPREFIX}"/etc/${PN}
+ --disable-editline
+ --disable-static
+ --enable-iconv
+ --enable-shared
+ $(use_enable static-libs static)
+ $(use_enable !minimal drivers)
+ $(use_enable !minimal driverc)
+ $(use_with unicode iconv-char-enc UTF8)
+ $(use_with unicode iconv-ucode-enc UTF16LE)
+ )
+ ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
+}
+
+multilib_src_install_all() {
+ einstalldocs
+
+ if use odbcmanual ; then
+ # We could simply run "make install-html" if we'd not had
+ # out-of-source builds here.
+ docinto html
+ dodoc -r doc/.
+ find "${ED}/usr/share/doc/${PF}/html" -name "Makefile*" -delete || die
+ fi
+
+ use prefix && dodoc README*
+ find "${ED}" -type f -name '*.la' -delete || die
+}