summaryrefslogtreecommitdiff
path: root/dev-db/tinycdb/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-db/tinycdb/files
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-db/tinycdb/files')
-rw-r--r--dev-db/tinycdb/files/tinycdb-gentoo.patch28
-rw-r--r--dev-db/tinycdb/files/tinycdb-uclibc.patch15
-rw-r--r--dev-db/tinycdb/files/tinycdb-umask.patch11
3 files changed, 54 insertions, 0 deletions
diff --git a/dev-db/tinycdb/files/tinycdb-gentoo.patch b/dev-db/tinycdb/files/tinycdb-gentoo.patch
new file mode 100644
index 000000000000..e8406b647d4b
--- /dev/null
+++ b/dev-db/tinycdb/files/tinycdb-gentoo.patch
@@ -0,0 +1,28 @@
+--- a/Makefile
++++ b/Makefile
+@@ -34,7 +34,7 @@
+ CDB_USELIB = $(LIB)
+ NSS_USELIB = $(PICLIB)
+ LIBMAP = $(LIBBASE).map
+-INSTALLPROG = cdb
++INSTALLPROG = cdb-shared
+
+ # The following assumes GNU CC/LD -
+ # used for building shared libraries only
+@@ -59,7 +59,7 @@
+ ChangeLog NEWS
+ DEBIANFILES = debian/control debian/rules debian/copyright debian/changelog
+
+-all: static
++all: shared
+ static: staticlib cdb
+ staticlib: $(LIB)
+ nss: $(NSS_CDB)
+@@ -128,6 +128,7 @@
+
+ do_install = \
+ while [ "$$1" ] ; do \
++ if [ ! -f $$1 ]; then shift 4; continue; fi; \
+ if [ .$$4 = .- ]; then f=$$1; else f=$$4; fi; \
+ d=$(DESTDIR)$$3 ; echo installing $$1 to $$d/$$f; \
+ [ -d $$d ] || mkdir -p $$d || exit 1 ; \
diff --git a/dev-db/tinycdb/files/tinycdb-uclibc.patch b/dev-db/tinycdb/files/tinycdb-uclibc.patch
new file mode 100644
index 000000000000..14e56bd7b6fc
--- /dev/null
+++ b/dev-db/tinycdb/files/tinycdb-uclibc.patch
@@ -0,0 +1,15 @@
+--- a/cdb.c
++++ b/cdb.c
+@@ -31,6 +31,12 @@
+ # define HAVE_PROGRAM_INVOCATION_SHORT_NAME
+ #endif
+
++#ifdef __UCLIBC__
++# ifndef __UCLIBC_HAS_PROGRAM_INVOCATION_NAME__
++# undef HAVE_PROGRAM_INVOCATION_SHORT_NAME
++# endif
++#endif
++
+ #ifdef HAVE_PROGRAM_INVOCATION_SHORT_NAME
+ # define progname program_invocation_short_name
+ #else
diff --git a/dev-db/tinycdb/files/tinycdb-umask.patch b/dev-db/tinycdb/files/tinycdb-umask.patch
new file mode 100644
index 000000000000..2a53babb2510
--- /dev/null
+++ b/dev-db/tinycdb/files/tinycdb-umask.patch
@@ -0,0 +1,11 @@
+--- a/cdb.c
++++ b/cdb.c
+@@ -21,6 +21,8 @@
+ #include <stdarg.h>
+ #include <fcntl.h>
+ #include <errno.h>
++#include <sys/types.h> /* umask() */
++#include <sys/stat.h> /* umask() */
+ #include "cdb.h"
+
+ #ifndef EPROTO