summaryrefslogtreecommitdiff
path: root/dev-db/timescaledb/timescaledb-2.11.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-09-04 16:21:31 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-09-04 16:21:31 +0100
commit0979d3ddb6ea14d17e52fd0ba2e01f928948384a (patch)
tree9d4f2f4d6cb3f7f6c2d65c815a075aa8ac3e52e0 /dev-db/timescaledb/timescaledb-2.11.2.ebuild
parenta8a8a3282ed1a28dd4ba31bc9b19914f25761abe (diff)
gentoo auto-resync : 04:09:2023 - 16:21:31
Diffstat (limited to 'dev-db/timescaledb/timescaledb-2.11.2.ebuild')
-rw-r--r--dev-db/timescaledb/timescaledb-2.11.2.ebuild67
1 files changed, 67 insertions, 0 deletions
diff --git a/dev-db/timescaledb/timescaledb-2.11.2.ebuild b/dev-db/timescaledb/timescaledb-2.11.2.ebuild
new file mode 100644
index 000000000000..83f98f57647b
--- /dev/null
+++ b/dev-db/timescaledb/timescaledb-2.11.2.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+POSTGRES_COMPAT=( 12 13 14 15 )
+POSTGRES_USEDEP="ssl"
+
+inherit postgres-multi cmake
+
+DESCRIPTION="Open-source time-series SQL database"
+HOMEPAGE="https://www.timescale.com/"
+SRC_URI="https://github.com/timescale/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+IUSE="proprietary-extensions"
+LICENSE="POSTGRESQL Apache-2.0 proprietary-extensions? ( timescale )"
+
+KEYWORDS="~amd64"
+
+SLOT=0
+
+RESTRICT="test"
+
+DEPEND="${POSTGRES_DEP}"
+RDEPEND="${DEPEND}"
+
+CMAKE_IN_SOURCE_BUILD=yes
+CMAKE_BUILD_TYPE="RelWithDebInfo"
+BUILD_DIR=${WORKDIR}/${P}
+
+src_prepare() {
+ postgres-multi_src_prepare
+ postgres-multi_foreach cmake_src_prepare
+}
+
+timescale_configure() {
+ local CMAKE_USE_DIR=$BUILD_DIR
+ local mycmakeargs=( "-DPG_CONFIG=/usr/bin/pg_config${MULTIBUILD_VARIANT}" "-DREGRESS_CHECKS=OFF" )
+
+ # licensing is tied to features, this useflag disables the non-apache2 licensed bits
+ if ! use proprietary-extensions ; then
+ mycmakeargs+=("-DAPACHE_ONLY=ON")
+ fi
+ cmake_src_configure
+}
+
+src_configure() {
+ postgres-multi_foreach timescale_configure
+}
+
+timescale_src_compile() {
+ local CMAKE_USE_DIR=$BUILD_DIR
+ cmake_src_compile
+}
+
+src_compile() {
+ postgres-multi_foreach timescale_src_compile
+}
+
+timescale_src_install() {
+ local CMAKE_USE_DIR=$BUILD_DIR
+ cmake_src_install
+}
+
+src_install() {
+ postgres-multi_foreach timescale_src_install
+}